Latest Visual Studio 2017 Update (V15.6.0) Hinders ReSharper

Just updated Visual Studio 2017 to version 15.6.0 and the message "Extension 'JetBrains ReSharper Ultimate 2017.3.3 11.0' likely caused 9 seconds of unresponsiveness. Disabling it may improve your experience." (Also at 11 seconds.)

The update ReSharper Ultimate is telling me that "[a]ll products are up to date."

What must I do to ensure that the extension functions as expected?

Thank you for your assistance.

17 comments
Comment actions Permalink

The Visual Studio developer team works hard on improving the startup time of Visual Studio. One effect is, that Visual Studio measures the load time of addins and give a performance warning, if an addin takes too long to initialize. There is a link beneath the message to surpress it in the future. You can read about it in the Visual Studio blog:

https://blogs.msdn.microsoft.com/visualstudio/2018/03/06/visual-studio-2017-version-15-6-visual-studio-for-mac-version-7-4-released/ 

Regards

Andreas

1
Comment actions Permalink

Hello,

I have same problem. 9 - 11 seconds. Clicking "Never show this message again" is not a solution. Resharper is really slow.
I have tried to go though performance guide and nothing helped. My projects also are not so big. It does not matter if it's clean installation of OS or VS2017.

Please, try to fix this problem. Thank you very much.

1
Comment actions Permalink

I have told the VS team my thoughts https://developercommunity.visualstudio.com/content/problem/209805/vs2017-extensions-1560.html. This appears to be a chicken/egg problem? We want the productivity gains ReSharper provides, but VS team says the load time takes too long. ReSharper is not the only extension that I am having challenges with. What are our options?

0
Comment actions Permalink

is it really so that R# doesn't work with VS 2017.6? Did you try the latest 2018.1 EAP build of R# (https://www.jetbrains.com/resharper/eap/)?

0
Comment actions Permalink

Today i updated my VS installation to Visual Studio 2017 15.6.1 and R# 2018.1 EAP2. I got the perfomance warning the first time i started Visual Studio, but because i clicked on the "ignore" link, consecutive starts of VS didn't show the message again. R# works as expected.

0
Comment actions Permalink

Resharper does a lot of extra analyses, which I assume causes the load time. I would not worry about it.

0
Comment actions Permalink

Pieter, I disagree.  This *is* worrisome.  ReSharper significantly slows down VS.  This message simply shines the light to that.  The plugin should do it's work in the background/asynchronously without slowing down the editor.  I get 7, 10, 15 second warnings all throughout the day which is very disappointing.

4
Comment actions Permalink

Clicking the "ignore" is only hiding the problem. I am a developer that believes "Warning" are as problematic as "Error" since it is 1) noise and 2) a concern that something could go amiss later on. I do worry about this because I have been bitten before. 

What can I do, personally, to improve R#, my experience, etc.? Let's work together to solve this!

1
Comment actions Permalink

Oz, I understand your point. I don't share your experience, mine is quick (enough). I did see this slowdown though, when working in a VM with not enough memory or with many open apps. Maybe ReSharper is memory hungry? I have 16GB on my laptop and 32 GB on my desktop.

By the way, besides the VS warnings, there are also ReSharper performance settings under ReSharper Options, Environment, Performance Guide. 

I have the following on Fix Silently

  • Do not download content on Startup
  • Disable XAML designer
  • Disable automatic formatting in Visual Studio
  • Disable codelens for all languages
  • Do not include Roslyn lightbulb actions in to Resharper's

 

0
Comment actions Permalink

Yes, I have gone through the Resharper "improve performance" settings.  That doesn't help.  I have 32GB of RAM, at least 16GB as I speak.  There's no way around it: ReSharper is SLOW.  It causes VS to freeze on a regular basis.

It would be nice if someone from the ReSharper team would comment here to acknowledge that this is a known issue and it's being addressed.

2
Comment actions Permalink

In general the performance warning of VS applies only on startup time. As R# has to do much work on startup naturally it takes longer until VS is up.

In the past i had repeatedly performance issues with several R# releases. Mostly they where project specific. For example, in the past i had to work on some bigger Visual Basic projects which performed really bad in contrats to similar sized C# projects. For some of the issues i was in direct contact to the developers and the Resharper team solved all my problems over the time.

There is a guide on how to configure VS and R# for performance here: https://www.jetbrains.com/help/resharper/2018.1/Speeding_Up_ReSharper.html.  And you could always add an issue to the error tracker on https://youtrack.jetbrains.com/issues/RSRP. You should decribe the characteristics of your project and maybe take a performance snapshot and add it or the issue (description how to do this is here https://resharper-support.jetbrains.com/hc/en-us/articles/207243205)

0
Comment actions Permalink

This is more than just a startup problem.  I see the delay messages throughout the day, even after startup.

I see warnings in all (C++, C#) projects big and small.  Anecdotally it feels like C++ is worse (C++ projects with comparable LOC to C# have larger slowdowns as reported by the warning).

1
Comment actions Permalink

I've applied all recommended R# settings for speeding up performance. Before the most recent VS update, R# would freeze startup for 11 to 15 seconds.

Post update, my reward was that "Jetbrains ReSharper Ultimate 2017.3.3 11.0 caused 32 seconds of unresponsiveness.

32 seconds of a frozen IDE, for two premium products working together.

 

0
Comment actions Permalink

I have the same problems. Have also gone through all the performance settings. Still getting the same warning. And it's not just on startup either. It also happens whenever I switch branch on git. I have 16 Gb RAM, Intel Core i7-6500U CPU @ 2.50 GHz, Windows 10 Pro. It should be good enough right? Some times the whole computer is semi-frozen, and the mouse marker is moving in jumps across the screen. I always run VS as administrator to be able to debug my web apps. I have also disabled the git integration in VS, which makes the VS experience somewhat less enjoyable. I am seriously considering clicking the "disable plugin" link as suggested by VS...

0
Comment actions Permalink

By way of update, my previous comment led to a support ticket being raised. I sent a profile/snapshot of the activity along to the guy who was managing the ticket.

The outcome was "Sorry but that's just how ReSharper works."

Microsoft's dev tools guys say that they are "talking to Jetbrains" about performance.

Personally, I have disabled the plugin and will seek free extensions.

 

0
Comment actions Permalink

Hello Svein-terje!

 

Could you please provide us performance snapshot as described in the following article?

Thanks in advance.

0
Comment actions Permalink

Just an FYI, I've updated to latest VS 15.6.7 with R# 2018.1 and was greeted with:

*sigh*

I put up with it, as this really only happens when you open a project.

1

Please sign in to leave a comment.