Performance of ReSharper Ultimate is unusable in Visual Studio 2017

JetBrains, you have a problem and it seems to be getting worse with every release.  Debugging with ReSharper enabled is completely unacceptable.  Just bringing up a QuickWatch window takes 15-30s.  Disable Resharper and it comes up immediately.  Instead of being an aid to developers, this product has become a boat anchor.

Non-debugging activities have similarly become a chore.  If I am waiting for ReSharper to catch up to my typing, usually 5-10s, it is not a benefit anymore.  

You guys need to fix this or loose customers.

Build: ReSharper Ultimate 2018.1 Build 112.0.20180414.70444 
Visual Studio Enterprise 2017 15.6.6

6 comments
Comment actions Permalink

Totally agree. Visual Studio is almost unusable with R# enabled. If I disable it, VS is very fast.

Plus I get lots of warnings from VS:

"You could speed up solution load by disabling Resharper"

"Resharper is slowing typing performance"

"Resharper likely caused 12s of unresponsiveness" etc etc

2
Comment actions Permalink

Hello!

 

Thank you for the feedback.

Sorry to know you've experienced performance problems.

To start with let me suggest to install the latest ReSharper 2018.1.2.
Also please try disabling all options in  ReSharper | Options| Tools | Debugger and check if performance is ok for you.
If the problem still persists could you please provide performance snapshot as described in the article? Please specify steps that lead to the problem in the snapshot details .
We'd be really grateful for assistance.
Thank you.

-1
Comment actions Permalink

Thanks for your response.

2018.1.2 is already installed.

I tried disabling the 3 debugging options, but it made no difference (note, my performance problems are more to do with text editor responsiveness, as opposed to debugging).

I took a performance snapshot, but after trying to upload it 3 times, it kept failing with this error:

. I can send it to you manually if that helps?

0
Comment actions Permalink

Hello Chris!

 

You can upload the snapshot file manually to JB servers as described here https://resharper-support.jetbrains.com/hc/en-us/articles/207635255-Uploading-Large-Files-for-JetBrains-Support-Team

Thank you.

 

 

0
Comment actions Permalink

Hi Angelina, I've uploaded the trace which demonstrates the text editor unresponsiveness:

https://uploads.services.jetbrains.com/

File uploaded: resharper_performance_profile__typing_unresponsive.zip

0
Comment actions Permalink

Hello Chris

Is the problem solved ?

 

Regards Niklas

2

Please sign in to leave a comment.