Issue: typing "override" followed by a space does not show members to override

Steps to reproduce:

1. Start Visual Studio 2005
2. Menu ReSharper -> Options -> Intellisense -> Code Completion
3. Make sure that the option "auto-popup after a character is typed" is
enabled
4. Click on "Ok"
5. Create a new class and name it MySection
6. Inherit from System.Configuration.ConfigurationSection
7. In the class MySection start typing "override", the intellisense kicks in
8. You don't need to this but hit , or to complete override 9. You will now notice that the list of members that are declared virtual in the base class are not popping-up. Workaround: after step 7 hit ]]> as you are typing override. Then after adding a space
behind the override keyword the list of members that can be overriden is
displayed.

--
Gabriel Lozano-Morán
The .NET Aficionado
http://www.pointerx.net


4 comments
Comment actions Permalink

Hello Gabriel Lozano-Morán,

Try using the Alt+Ins to generate code, or ReSharper->Code->Generate code...
and then select "Override inherited members".

Ed

Steps to reproduce:

1. Start Visual Studio 2005
2. Menu ReSharper -> Options -> Intellisense -> Code Completion
3. Make sure that the option "auto-popup after a character is typed"
is
enabled
4. Click on "Ok"
5. Create a new class and name it MySection
6. Inherit from System.Configuration.ConfigurationSection
7. In the class MySection start typing "override", the intellisense
kicks in
8. You don't need to this but hit <enter>, <tab> or <space> to
complete
override
9. You will now notice that the list of members that are declared
virtual in
the base class are not popping-up.
Workaround:

after step 7 hit <esc> as you are typing override. Then after adding a
space behind the override keyword the list of members that can be
overriden is displayed.



0
Comment actions Permalink

Hello Ed

This is merely a work-around I am aware of workaround but unfortunately i am
not the kind of guy that settles with workaround :)

--
Gabriel Lozano-Morán
The .NET Aficionado
http://www.pointerx.net

"Ed Chapel" <echapel@crosscurrentinc.com> wrote in message
news:106baec83f7f8c85844a86ff1a6@news.jetbrains.com...

Hello Gabriel Lozano-Morán,

>

Try using the Alt+Ins to generate code, or ReSharper->Code->Generate
code... and then select "Override inherited members".

>

Ed

>
>> Steps to reproduce:
>>
>> 1. Start Visual Studio 2005
>> 2. Menu ReSharper -> Options -> Intellisense -> Code Completion
>> 3. Make sure that the option "auto-popup after a character is typed"
>> is
>> enabled
>> 4. Click on "Ok"
>> 5. Create a new class and name it MySection
>> 6. Inherit from System.Configuration.ConfigurationSection
>> 7. In the class MySection start typing "override", the intellisense
>> kicks in
>> 8. You don't need to this but hit , or to >> complete >> override >> 9. You will now notice that the list of members that are declared >> virtual in >> the base class are not popping-up. >> Workaround: >> >> after step 7 hit as you are typing override. Then after adding a >> space behind the override keyword the list of members that can be >> overriden is displayed. >> >]]>



0
Comment actions Permalink

Hello Gabriel Lozano-Morán,

A better work around than pressing the escape key is if you just type an
additional space (so that there are two spaces after the override keyword).
Then the override options will popup and when you select one, it adds the
method stub and eliminates your double spaces. So, to do the override, you
just hit the space bar after selecting the override in RS intellisense and
it works.

~Andy Alm

Hello Ed

This is merely a work-around I am aware of workaround but
unfortunately i am not the kind of guy that settles with workaround
:)

"Ed Chapel" <echapel@crosscurrentinc.com> wrote in message
news:106baec83f7f8c85844a86ff1a6@news.jetbrains.com...

>> Hello Gabriel Lozano-Morán,
>>
>> Try using the Alt+Ins to generate code, or ReSharper->Code->Generate
>> code... and then select "Override inherited members".
>>
>> Ed
>>
>>> Steps to reproduce:
>>>
>>> 1. Start Visual Studio 2005
>>> 2. Menu ReSharper -> Options -> Intellisense -> Code Completion
>>> 3. Make sure that the option "auto-popup after a character is typed"
>>> is
>>> enabled
>>> 4. Click on "Ok"
>>> 5. Create a new class and name it MySection
>>> 6. Inherit from System.Configuration.ConfigurationSection
>>> 7. In the class MySection start typing "override", the intellisense
>>> kicks in
>>> 8. You don't need to this but hit , or to >>> complete >>> override >>> 9. You will now notice that the list of members that are declared >>> virtual in >>> the base class are not popping-up. >>> Workaround: >>> after step 7 hit as you are typing override. Then after adding >>> a space behind the override keyword the list of members that can be >>> overriden is displayed. >>>]]>


0
Comment actions Permalink

Hello Gabriel,

this is a problem indeed, I've created a request:
http://www.intellij.net/tracker/resharper/viewSCR?publicId=26416

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Steps to reproduce:

1. Start Visual Studio 2005
2. Menu ReSharper -> Options -> Intellisense -> Code Completion
3. Make sure that the option "auto-popup after a character is typed"
is
enabled
4. Click on "Ok"
5. Create a new class and name it MySection
6. Inherit from System.Configuration.ConfigurationSection
7. In the class MySection start typing "override", the intellisense
kicks in
8. You don't need to this but hit <enter>, <tab> or <space> to
complete
override
9. You will now notice that the list of members that are declared
virtual in
the base class are not popping-up.
Workaround:

after step 7 hit <esc> as you are typing override. Then after adding a
space behind the override keyword the list of members that can be
overriden is displayed.



0

Please sign in to leave a comment.