Underscore for line break is autocompleted to _AppDomain

To break up a statement into multiple lines in VB.net (<4.0) a space followed by a line break is required.
With resharper installed this is always autocompleted to _AppDomain.
This makes the already tedious action of breaking a line even more tedious.

Can this behaviour be configured somewhere?

2 comments
Comment actions Permalink

Hello Boris
     This happens because you have '_AppDomain' pre-selected in the completion list prior to pressing Enter. In this situation you can either:
     1. Explicitly close IntelliSense window with Esc before pressing Enter
     2. Change the autopopup option to 'Display but do not preselect' for 'Letter and digits' context under ReSharper | Options | IntelliSense | Autopopup | VB.NET

     Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

http://www.jetbrains.com


"Develop with pleasure!"

0
Comment actions Permalink

Closing with escape is what we do right now, but you can imagining this becomes rather tedious quite fast
The other option looks promising, will check it out. Thx :)

0

Please sign in to leave a comment.