Resharper not available in Visual Studio 2017.3

After successfully installing Resharper Ultimate 2017.2 it is listed as enabled extension under Tools/Extensions but no functions to find (main menu, context menu, options dialog)

7 comments

Hello Igor,

I already found this link and tried/checked everything. I re-installed VS 2017.3.3, installed Resharper 2017.2 (full installer) as adminstrator with virus check disabled, run with command line /resetskippkgs as admin, all Resharper files listed are present. There is still no Resharper menu item or options page available.

Is it important that I use Windows7 Enterprise edition?

Can I help you with more information or log files? Just for completeness Resharper is available on the same machine under VS 2015.3 and in suspend mode (because it is not working in VS 2017).

Thanks in advance.

 

0

Axel,

Could you please try this advice - https://youtrack.jetbrains.com/issue/RSRP-465919#comment=27-2402572 (please note that it will remove all settings for VS2017, so you might want to back up the file first)?

0

Thanks, Resharper is now available.

0

Hi again,

after updating VS 2017 to version 2017.3.5 Resharper is gone again (almost) completly. It is only listed again in the extension list. (Not under Tools/Options)

All listed action did not help. Deleting the VS2017 settings file is not possible anymore. Then VS will not start.

The VS2017 log file (created with /log option) says that Resharper is loaded and enabled.
Any further ideas or suggestions?

 

 

 

 

 

 

0

Hello Axel! Let's try it in a slightly different way:

  1. try removing "privateregistry.bin" file
  2. run "ReSharper Ultimate" installer without elevations, it will generate privateregestry.user.bin file during installation to VS2017
  3. run Visual Studio as you usually run it. VS will add needed info to the file
  4. check ReSharper there.  

Thanks! 

1

Thanks for the help. Resharper is available now. It will hopefully not get lost again after next VS 2017 update.

0

Please sign in to leave a comment.