Highlight color for selected argument is hard to see clearly

Answered

Hello.

Highlight color for selected argument is hard to see clearly, How to change it?

 I have tried almost all items under the Fonts and Colors tab:(

unselected:

selected:

another higllight color I want to change:

7 comments
Comment actions Permalink
Official comment

Hello

Try to change:  

1) "ReSharper Matched Format String Item" | Item background

2) "Highlighted Definition" | Item background

Thanks! 

Comment actions Permalink

Thank you Alexander:)

0
Comment actions Permalink

I'm using Visual Studio Enterprise 2019 version 16.2.5 with ReSharper Ultimate version 2019.2.2.

The format arguments within methods such as the string.Format() method, do not display as a different color.

Example:

I have tried almost all items under the Fonts and Colors tab and cannot find a way to change the color of the format arguments.

When I was using Visual Studio Enterprise 2015 version 14.0.25431.01 Update 3 with ReSharper Ultimate version 2016.1.2, the format arguments displayed as a different color.

Example:

Where can I make an update within ReSharper Ultimate version 2019.2.2 to ensure the format arguments display as a different color within the code editor?

 

0
Comment actions Permalink

Hello Steve,

 

Could you please check that ReSharper | Options | Code Inspection | Settings | Color Identifiers is turned on?

Thank you.

0
Comment actions Permalink

Hello Angelina,

Yes, while researching this problem extensively I did turn on Color Identifiers before submitting my help request:

I've also tried to Repair the ReSharper installation, then I disabled the ReSharper extension and then reenabled it.  

I also tried to edit the C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise\Common7\IDE\Extensions\extensions.configurationchanged file (per https://resharper-support.jetbrains.com/hc/en-us/articles/206546479-ReSharper-Fonts-Colors-settings-do-not-appear-in-Visual-Studio-after-installation)

JetBeans.Annotations is also set as the default namespace:

I've also checked and double-checked all the Tools > Options > Environment > Fonts and Colors > ReSharper* items.

I hope this helps.

Steve

0
Comment actions Permalink

Hello Steve,

 

Please try changing VS Tools | Options | Environment | Fonts and Colors | ReSharper Format String Item color.

Hope it helps.

Thank you

0
Comment actions Permalink

Hi Angelina,

I am facing the same problem as Steve. I am running ReSharper Ultimate 2019.3.2 on VS 2015. Have checked all settings suggested. Please help!

0

Please sign in to leave a comment.