double click text selection doesn't work correctly

When I have ReSharper enabled, double clicking on a word doesn't always select the text ( double click then <ctrl>+c is a common part of my workflow). I can usually reproduce this behavior with the following steps.

1. Enable ReSharper, restart VS.

2. Open a .cs file and click once in a variable name to place cursor.

3. Double click in the same place.


When resharper is disabled, the word is selected as expected after a double-click action. When resharper is enabled, nothing happens.


c# VS 2022 community, resharper v 222.0.20220808


Could you please specify in what type of files the issue is reproduced?
Thank you.

Yes, this is just working with .cs files. I changed some of the Resharper keyboard shortcut settings (i'm not sure which), and now double click to select text is working


thank you for the reply.
If you let us know what the shortcut it was, we'd be very grateful.

I have the same behaviour in .cs files. It seems, that VS is too busy in that moment to select the text. Sometimes I have to do it three times in a row to get the text selected.

I created a little gif. It worked direcly with the first try.

The first double click only behave like a single click. Just with the second double click I have selected the text.


It seems that it act rather on big VS projects than on small ones.


Hello T Blatt, thank you for your comment. I was able to reproduce this problem with ReSharper enabled and disabled. Also, we discussed the issue with our development team, and it looks like it's not caused by ReSharper. Please let me know if you have any questions.


I'm running into the same problem, and I have a feeling it has something to do with multiple monitors.
My primary monitor is 4k resolution and my secondary monitor is FHD resolution, and I'm normally used to displaying code on the secondary screen.
Once I moved the VS window to the primary display, the problem went away.


Hi Maria Pleskunina 

100% to do with R#. 

When u say "I was able to reproduce" then "not caused by ReSharper"… that's not quite right, I mean logically that doesn't sound quite right does it? 

Been plaguing me for years. 

Reason I stopped my subscription and now I have installed again (after many years of NOT using R#) I remember WHY I stopped my sub(s) and uninstalled. 

Soooo horribly annoying 200x a day. 

Guess is that it's not "directly R#" but that the extra load R# puts on VS means the bug/issue emerges. 

Please please fix/at least get the devs to give us some usage tips to try and make the problem go away/less prevalent. 

About 50% of my double clicks are NOT captured as such when R# is enabled. 100% when its disabled.  I will not buy my team any new subs when my trial runs out if can't sort this - for me it more than outweighs the benefits of having R# running.   

Thanks for help and any progress on this would be amazing - do love R# but this is show stopper for me and our team (was about to recommend R# licences to the C level at co I'm contracting for too)!  


Hello Bcameronsmith,

thank you for contacting us.

We tried to reproduce this problem several times and we were able to observe such behavior even when ReSharper was suspended. That's why we say that the problem is not on ReSharper's side.

Maybe this is related to “the extra load R# puts on VS ”.

We are sorry for the inconvinience.


Any update on this issue solution?

because I am also facing same issue since 2 years, any workaround?



thank you for contacting us.

Unfortunately, we don't have any workaround here.

We tried to reproduce this problem several times and we were able to observe such behavior even when ReSharper was suspended. That's why we say that the problem is not on ReSharper's side.e


Please sign in to leave a comment.