Resharper Killing Typing Performance in Visual Studio 2022

I am currently working in a large solution with several hundred projects. Typing in any file in any project has become very sluggish with ReSharper enabled. Disabling ReSharper makes visual studio useable again. However, so many of the dot ultimate tools (build, test running, profiling, coverage analysis, code clean-up on save) are essential for my productivity. Is there any way to configure dot ultimate / ReSharper so that it does nothing when I type whilst still giving me the aforementioned functionality? I think that I have been through and switched off all the relevant settings that I can see but typing performance is still poor.

6 comments
Comment actions Permalink

Hello David!

Thank you for contacting us.

You can try following the speed-up steps described here: https://www.jetbrains.com/help/resharper/Speeding_Up_ReSharper.html

Also you could try a (slightly unconventional) workaround for memory traffic described in `Reducing Memory Usage with Large Solutions` part here: https://blog.jetbrains.com/dotnet/2020/05/11/story-csproj-large-solutions-memory-usage/.

Please help us to determine the cause of the issue by profiling Visual Studio - follow the instructions described here: https://resharper-support.jetbrains.com/hc/en-us/articles/207243205 to collect a snapshot.

Thank you!

0
Comment actions Permalink

Hi Olga.

Thanks for this. I've been through all the performance optimisations and the situation is still pretty bad. I've managed to track the situation down to be related to having executed tests. I have a solution that contains around 250 projects and 20000 tests. If I run all tests in the solution, typing performance degrades massively thereafter. I must then delete all tests from the test session, close and reopen the solution for performance to get better. This doesn't happen to colleagues running all tests for the same solution with the same hardware so it appears to be something to do with configuration.

Any ideas for how I may be able to resolve this would be greatly appreaciated.

Thanks

0
Comment actions Permalink

Hi David, thank you for your reply.

I must then delete all tests from the test session, close and reopen the solution for performance to get better.

Do you stop tests before deleting them?

Also, please let me know the following information:

- What value do you have for "Run up to ... test runners in parallel" option in "ReSharper | Options | Tools | Unit Testing | General"?

- How many cores does you processor have (Ctrl+Shift+Esc | select the Performance tab)?

- Do you have enabled "Shadow-copy assemblies being tested" in "ReSharper | Options | Tools | Unit Testing | Test Runner"?

Thank you!

0
Comment actions Permalink

I have run up to 12 test runners in parallel configured.

I have 6 cores (12 logical processors).

Shadow copy assemblies being tested is set to none.

These are the same settings as colleagues with the same hardware.

Thanks

0
Comment actions Permalink

I don't stop the tests before deleting them as they have already completed.

0
Comment actions Permalink

Hi David, thanks for the additional information.

These are the same settings as colleagues with the same hardware.

Do I understand correctly that despite the fact that colleagues have the same settings, they do not have the same performance problem? Also, what ReSharper version are you and your colleagues using? Is it 2022.2.4?

If the answers to both questions are yes, then please collect a performance snapshot for us using the steps described here. Thanks in advance!

0

Please sign in to leave a comment.