Stopping ReSharper from moving #Pragma's and #Regions to baseline

ReSharper seems to have a habit of moving #Pragma and #Region statements to the baseline instead of keeping exiting indents when doing some other procedure. I want to stop this. It's not consistent with our coding style. What option shuts this off?

thanks

Harv

2 comments
Comment actions Permalink

Hello Harveyb, thank you for your question. Please take a look at settings here: "ReSharper | Options | Code Editing | C# | Formatting Style | Tabs, Indents, Alignment | Preprocessor directives". Let me know if you have any questions. Thank you!

0
Comment actions Permalink

Thank you Maria. I will change all three to "do not change", hopefully, that solves it.

0

Please sign in to leave a comment.