RS Ultimate crashes VS 2019 loading XML files

RS has started crashing VS 2019 at startup while "Processing files" since installing the latest version. This happens even if a solution is not loaded into VS.

I manually deleted all folders under AppData\Local\JetBrains\Transient\ReSharperPlatformVs16\v213_e355273f\SolutionCaches

This made no difference.

The only option seems to be suspending RS. If it isn't suspended during "Processing files" VS will crash and restart, leading to a crash loop.

Note: I run VS as Administrator

Resharper 2021.3.2

dotCover 2021.3.2

Visual Studio Professional 2019 16.10.2

Microsoft .NET Framework 4.8.04084

Windows 10 Enterprise 10.0.19042

Comment actions Permalink

After further testing, the crashing problem seems to happen when RS is enabled and File > Open > Folder is chosen in VS on a solution folder with a large number of XML files. This causes RS to start loading every XML file in that folder (and child folders) until it runs out of memory and crashes VS.

It starts out minimized on the VS notification bar as 'Processing Files':

Clicking on 'Processing Files' brings up this dialog:

Clicking Cancel just minimizes it again. It doesn't stop it from loading files. The only way to stop it is to load a solution (.sln) in time before it crashes VS.

This is the underlying bug that was causing the crashes. Please fix this bug ASAP

Comment actions Permalink

Owen Ward, thank you for the report. Please add the following line to %AppData%\JetBrains\Shared\vAny\GlobalSettingsStorage.DotSettings file to change a Performance Threshold for XML files:

<s:Int64 x:Key="/Default/PerformanceThreshold/AnalysisFileSizeThreshold/=XML/@EntryIndexedValue">300000</s:Int64>

The default is 300000 bytes, try decreasing it. Please let me know how it works for you. Thank you!

Comment actions Permalink

I set AnalysisFileSizeThreshold to 1000. I also tried setting it to zero. It made no difference. It seems to be ignoring that setting.

This is definitely a bug. It just started happening with one of the recent RS updates.

The way to reproduce it is to load a folder in VS instead of a .SLN

It keeps loading XML files until VS crashes.

Comment actions Permalink

Owen Ward, thanks for the reply. Could you please collect some debug information for us using the following steps? Please note that we need only the `Output` file. After that, please send us a request using the "Submit a request" button with the result attached. Thanks in advance!


Please sign in to leave a comment.