ReSharper spacing and typing bug

Answered

After the latest ReSharper update, there are all sorts of text display and typing bugs. As you can see in the screenshot below, the way spaces display is highly inconsistent (there is only one space before each "=" in the actual code).

Even worse, it makes typing impossible because it will start typing in random places, and even worse, it will change locations while I'm typing. Sometimes it will even type backwards (right to left)!

When I copy and paste a single line of code, it will paste many many times instead. However I don't think the text is actually there as I can't highlight it, it just displays that way.

ReSharper is basically unusable. I tried resetting all settings to default and that did NOT fix it. In addition, when it starts bugging out (which is usually within a minute after opening Visual Studio), all the Visual Studio context menus will stop working too. Disabling ReSharper fixes all these issues.

8 comments
Comment actions Permalink
Official comment

Hello Bharadwaja,

We're very sorry for the inconvenience! We're going to release 2021.1.5 with a fix for this problem as soon as possible.

As a workaround, please disable Inlay Hints in ReSharper | Options | Environment | Inlay Hints | General or downgrade to 2021.1.3.

Thank you!

Comment actions Permalink

Hello,

I am experiencing the same as above and additionally when pressing on the save all/ save file buttons, they seem to hang (backround stays blue) until I close all files and reopen any file and hit the buttons again.

I also tried updating to resharper 2021.1.4, reinstall resharper and setting all settings to default, nothing works.

Greetings

0
Comment actions Permalink

Hello David Kellerberg, please use one of the workarounds described above:

- disable Inlay Hints in ReSharper | Options | Environment | Inlay Hints | General

or

- downgrade to 2021.1.3

The 2021.1.5 bugfix is on the way. We're terribly sorry for the inconvenience.

1
Comment actions Permalink

As well as spacing issues I am also getting paste issues, with it pasting multiple times

It won't undo either and I have to shut the file.

1
Comment actions Permalink

Hello Chris, thanks for the report. Please use the workarounds described earlier, do they help?

0
Comment actions Permalink

Hi Maria,

for me disabling the inlay hints option works all problems are gone.

greetz

0
Comment actions Permalink

David Kellerberg, thank you for letting me know. Great to hear that!

0
Comment actions Permalink

Hello everyone! We have released 2021.1.5, please update ReSharper to get the fix.

0

Please sign in to leave a comment.