Resharper is not working in Blazor webassembly application

I need to check the performance for blazor web assembly application by using Resharper. So I have created blazor web assembly application. After build the sample, to check the performance in Resharper by using "Run Startup Configuration Performance Profiling" option. Then, Sample is run in browser, but the resharper's performance profile window is not responding after browser is opened. Please refer the screenshot for the issue.

Resharper's performance profile window

I also tried the same sample in blazor server side application, Resharper's performance profiling tab is working.

Please give some resolution for this problem

.

ReSharper: JetBrains.dotUltimate.2021.1.2

Visual studio: Microsoft Visual Studio Professional 2019 Version 16.9.1

 

Also we posted a query in stackoverflow. Please refer the following link.

https://stackoverflow.com/questions/67470559/resharper-is-not-working-in-blazor-web-assembly-application

4 comments
Comment actions Permalink

Hello,

Unfortunately, dotTrace (JetBrains .NET Performance profiler) does not support profiling client-side Blazor WebAssembly application since it's not a common .NET process.

0
Comment actions Permalink

Hi Konstantin Katsnelson,

Could you please suggest some other tool to validate the performance with blazor web assembly?

 

9
Comment actions Permalink

Could you please suggest any other tool for performance validation in blazor web assembly?

4
Comment actions Permalink

It looks like the best option for a Blazor Web Assembly profiling is Chrome Dev Tools. See the following post for details: https://remibou.github.io/Profiling-in-Blazor/

0

Please sign in to leave a comment.