ReSharper wants to remove "Get" from beginning of method name

I just updated to R# 2021.1.20210409.161805.  Now ReSharper is asking me to rename all sorts of methods that are named correctly.  The examples I've found so far all have to do with stripping "Get" from the beginning of the names of methods that, well, get something.

What's going on here all of a sudden?

5 comments
Comment actions Permalink

Ron Warner, thank you for your question. Could you please check what value is set for Methods here ReSharper | Options | Code Editing | C# | Naming Style? A screenshot with these settings can also be helpful. Thank you!

0
Comment actions Permalink

Here's something interesting... it indicates that auto-detected rules are turned on, however, when I first encountered this problem, I used the Alt+Enter context menus to disable auto-detected rules.  I suppose it must not have stuck.  Editing it here in the options was successfully saved, but it did not affect the problem I'm having.

For what it's worth, yesterday, in the below dialog, I added an additional method_rule in the form GetUpperCamelCase, but I could not get that additional setting to actually stick to my dotsettings.  That was a hack at best, anyway.

0
Comment actions Permalink

Ron Warner, have you tried disabling "Use auto-detected rules"? 

0
Comment actions Permalink

Maria Pleskunina - Yes, I addressed this in my previous response.  Trying to disable auto-detected rules via the Alt+Enter context menus did not work, but I was able to do so by editing the options directly.  However, the problem is still there, even with auto-detected rules disabled.

0
Comment actions Permalink

Ron Warner, as far as I can see, you also have the editorconfig settings applied. Could you please take a look at the naming rules that are described there?

If the problem persists please contact us via "Submit a request" and attach ReSharper settings: ReSharper | Manage Options | "Export to File" in the context menu for each layer. Also, please attach editorconfig file.

Thanks in advance!

0

Please sign in to leave a comment.