7 comments
Comment actions Permalink

I was able to exclude by adding the file to Generated Code, but that is not what this file is (it's a license file).

0
Comment actions Permalink

Actually, that does not work because that change is not saved to the project, therefore will not be shared with the team.

0
Comment actions Permalink

Keith Davis, thank you for your question.

You seem to be using a fairly old ReSharper version. The UI has changed since then and documentation is shown for the latest 2020.3.2 version.

To exclude files from ReSharper analysis add them to ReSharper | Options | Code Inspection | Settings | Elements to skip.

I would also like to let you know that if you click the Save button, the setting will be saved by default to the This computer layer. If you need to save the setting to another layer, click the Save To and select a specific layer.

Please let me know if you have any questions.

0
Comment actions Permalink

Maria Pleskunina

You seem to be using a fairly old ReSharper version. The UI has changed since then and documentation is shown for the latest 2020.3.2 version.

No, I'm using the latest version. I had just updated the extension before I tried to use this feature.

 

0
Comment actions Permalink

Keith Davis thanks for the reply. Are there any results if you search for "elements to skip" in ReSharper options?

0
Comment actions Permalink

How strange, the setting "just appeared"!

 

0
Comment actions Permalink

Great to hear that! Please let me know if you have any other questions.

0

Please sign in to leave a comment.