TestRunner: Application JetBrains.Rd.Tasks.RdFault net5.0


R# version 2020.2.4


After updating a test package to run net5.0 we get:

ERROR TestRunner: Application JetBrains.Rd.Tasks.RdFault: Could not load file or assembly 'System.Runtime, Version=


The VS Test Runner is green, and Github AppVayour build is green.

This is done:

ReSharper | Options | Tools | Unit Testing | General | "Default .NET Framework version:" to the "Automatic" value.

I see there is not net5.0 in the Default .NET Framework version. is this why?


You can test yourself my pulling https://github.com/castleproject/Windsor

and running Castle.Windsor.Extensions.DependencyInjection.


NB netcoreapp3.1 as test framework appears to be running in R# also




Comment actions Permalink

Hello Rsr,

I don't see any tests in the "Castle.Windsor.Extensions.DependencyInjection" project. Do you mean "Castle.Windsor.Extensions.DependencyInjection.Tests"?

Could you please run Visual Studio with the following command line: 'devenv /ReSharper.LogFile C:\log\resharper_log.txt /ReSharper.LogLevel Verbose'? After that reproduce the issue and upload the 'resharper_log.txt' file to the JB server via https://uploads.jetbrains.com/ form.

Thanks in advance!

Comment actions Permalink

Yes i ment Castle.Windsor.Extensions.DependencyInjection.Tests. Did you try to replicate with the GitHub repository link i sent? Did it work for you?

If I change to netcoreapp 3.1 it is ok, net5.0, it isn't. I cannot see why you should not be able to replicate?

I have uploaded the file, but i think it is better you replicate yourself.



Comment actions Permalink

Rsr, thanks for the reply. Yes, I cannot reproduce the problem with your solution when "Default .NET Framework version:" is "Automatic". However, I tried to change this value with another one and got the same error.

Please try clearing caches via "ReSharper | Options | Environment | General | Clear caches". Does it help?

If not, do you have the option to try the latest ReSharper 2020.3.1?


Please sign in to leave a comment.