Locks cursor

Answered

If the cursor is between t and ( in the following picture and I start typing Resharper locks the cursor, so I can't move it up or down.

Is there a way to prevent the "No suggestions" dialog

1 comment
Comment actions Permalink
Official comment

Hello Karsten,

What ReSharper is trying to do is suggest a name for the property, based on the type. If it's a void or bool property, there's not much it can suggest, but if it's a complex type, such as Address, then it can suggest a name such as Address. Also, if it's a List<Address>, ReSharper will suggest Addresses or List. So, it can be useful.

However, it isn't terribly helpful to show No suggestions - it might be nicer to just not show anything if the list is empty.

In order to switch focus and close drop-down option "No suggestions" you may use any of the below methods:
1. The button Esc
2. Left/Right arrows
3. Disable IntelliSense for "Letter and digits" at ReSharper | Options | Environment | IntelliSense | Autopopup

There is also an existing request, so you can upvote it and track: RSRP-453668 

Please sign in to leave a comment.