Resharper crashes VS with SDK style projects and large solution

Our team used to use the traditional style projects (C#) in Visual Studio.  We had 580 projects in our solution and Resharper worked great!  One day we switched to SDK style projects and Resharper hangs all the time.  We can only get it to work if we have less than 200 projects.  At least 5 developers have tried it on their machines and we all get the same results.  So we have to disable Resharper.  It has been this way for 6 months now.  Just enabled it again with latest VS and latest Resharper and still hangs.  

One major difference between traditional style projects and SDK style projects is that the traditional project files named every CS file that was in the project.  There was a finite explicit list.  With SDK projects VS (and I assume Resharper) have to scan the folder for every CS file and load them all.

To be fair, VS is also more sluggish.  Extra 30 second delay every time we build.  If that file scanning is indeed the issue, wondering if Resharper can be modified to cache the files between runs, and update the list in the background or something.  The first thing I do after loading a solution is to press Control-T to look for the class I'm going to work on.  Now I must use the built in Control-T that VS provides, and it is horrible compared to how Resharper used to work.

Can you reproduce this?  Can you fix this?  You can certainly use me as a tester to see if some experimental code makes it better for large solutions.

Thank you. - Jeff

2 comments
Comment actions Permalink

And before someone says "Hey dummy, make your solution smaller.", we already did.  Down to 340 projects, still hangs.  Experimentation shows we'd need to get below 200 before it barely starts working.  Considering it worked great with 580 projects, there has to be reasonable way to get this working with more than 200.

0
Comment actions Permalink

Hello Jeff,

 

thank you for the feedback.

To begin with, please collect a dump for us using this article -  https://resharper-support.jetbrains.com/hc/en-us/articles/206546619. You can share it privately via "Submit a request" form at the top of the page.

Also, please try disabling the following option - ReSharper | Options | Environment | General | Read solution model directly. Does it make any difference?

Thank you.

0

Please sign in to leave a comment.