Disable new line comment

When I press 'enter' at the end of a comment line in order to insert a new line bellow it, ReSharper is automatically making that new line a comment.

I've looked to try and turn that off but I don't really know what to call the feature so have not had any luck.

Also read the similar posts and those don't seem to be quite the same thing.

Anyway it's driving me crazy, I really don't like that behavior.  

I hope someone can tell me how to turn it off.

Thanks.

4 comments
Comment actions Permalink

Hello,

You can turn auto-extending with the "Insert * on Enter after /*" setting.

We'll add a separate option to control that behavior (https://youtrack.jetbrains.com/issue/RSCPP-30276) and also update the logic so that immediate Enter on a new comment line stops auto-extending (https://youtrack.jetbrains.com/issue/RSCPP-30277).

0
Comment actions Permalink

ah, perfect!

Splitting up that setting does seem like a nice idea.

I can see how if I wanted to press enter at the end of the first line of

/* My life story: 

*/

to get

/* My life story

*

*/

That would indeed be handy.

 

However, pressing enter on 

Dear doe; //A female dear

to get

Dear doe; //A female dear

//

That is frustrating because of course i'm not trying to make that next line a comment.

I'm happy to sacrifice the first helpful thing to prevent the second more frequent (for my commenting style) annoying thing for now though. 

Thanks so much for you help!

0
Comment actions Permalink

In your second example R++ shouldn't extend the comment. // should only get inserted after return in a multi-line comment.

0
Comment actions Permalink

My bad, you are correct. I had not quite pinned that difference down.

It's when going from the end of the second line 

//first

//second

to

//first

//second

//

that was in fact what was bugging me.

Still disabling that option stops that so thank you.

0

Please sign in to leave a comment.