Automatically adding #region and #endregion to usings

After I messed with some ReSharper settings (C#), it started adding "#region" and "#endregion" surrounding the using directives whenever I run a full Code Cleanup.

Does anyone know what setting in ReSharper is causing this? I need to disable it.

4 comments
Comment actions Permalink

Hello,

 

Sorry for the delay in responding.

Could you please provide all dotSetting files via ReSharper | Manage Options | right-click on each layer | Export to file. Please submit them using "Submit a request" form at the top of the page.

Thank you.

0
Comment actions Permalink

Hello,

as I'm facing the same problem, I would love to know how it was solved. I'm struggling for a while with this. There seems to be no obvious way to remove the regions around the usings. :-(

Kind regards

0
Comment actions Permalink

Under "Code Cleanup", remove the "Embrace 'using' directives in region" checkbox.

0
Comment actions Permalink

Thank you for that answer. I've seen that setting and it was already unchecked. Maybe it overlapped with some other profile, whereas this setting was effectively shown as not checked. Hmm..

But meanwhile I anyway reset all my settings and recreated the entire file layout and stuff like that, and now it disappeared.

0

Please sign in to leave a comment.