Can't add folder to elements to skip, yet it's being analyzed

Answered

In our solution, we have a nuget packages folder that I want to exclude from solution wide analysis.  However when I try to do that it says it's not part of the solution and wasn't added to the exclude list.  But if it's not part of the solution, why is it being included in the solution wide analysis?  These are all 3rd party code and I don' want to bog down the analysis with them.  How can I exclude them?

9 comments
Comment actions Permalink

Hello,

 

Please accept my apologies for the delay in responding.

Could you please specify what kind of files you are trying to exclude?

Possibly ReSharper | Options | Code Editing |Third-Party Code could be helpful in your case. Though please note that is applied only to non-C# language files.

Thank you.

0
Comment actions Permalink

I'm trying to specify folders, not files.  The folder structure is as follows

src
  solutionfile.sln
  packages
    third party nuget packages
  project1
  project2

So, the main solution file is in the src directory and when I try to select the packages folder in Skipped Code or Library Code, I get the error message that "Some selected folders are not part of the solution and were not added". 

I know that I don't have the packages folder added to the solution as an included item, so that would make sense to get that message.  But if that's the case, why does resharper still include it in solution wide analysis and report errors?

0
Comment actions Permalink

Could you please try disabling ReSharper | Options | Environment | General | Read solution model directly and check if the specified folders are still analyzed.

Please let me know about the results.

Thank you.

0
Comment actions Permalink

Doing that didn't change anything.  I still can't select the packages folder and get the same error message.

0
Comment actions Permalink

I have the exact same problem,

I would like to exclude NuGet packages from Search Everywhere, but no matter where I try to I get the same error, "Some selected folders are not part of the solution and were not added". 

Is there a solution to this?

0
Comment actions Permalink

Hello Bhc, thanks for the question. Could you please clarify the name of the NuGet package?

Also, please attach a screenshot that will illustrate the problem. Thanks in advance!

Gswartz please let me know if the problem is still relevant to you. Thank you!

 

0
Comment actions Permalink

There is no single NuGet package causing a problem.
The problem is that ReSharper scans and searches the various text files the are included in the /packages folder in a project.
This causes a lot of results since there are binary and base64 data in those folders, which any search can basically match.

 

0
Comment actions Permalink

and this is a screenshot illustrating the problem.
It doesnt find the places in the code i have ngrok but the encoded strings that have the capital letters..

0
Comment actions Permalink

Bhc, thanks for the additional information! I've submitted a new feature request to our bug tracker: https://youtrack.jetbrains.com/issue/RSRP-485792. Please feel free to comment or vote for it to be notified about status changes.

As a workaround, please use "Go to Text" (Ctrl+T 3 times or Ctrl+N 3 times). Please let me know if you have any questions. Thank you!

0

Please sign in to leave a comment.