AutoComplete inserts blank

Completed

When I attempt to use the auto complete on a variable or function name, instead of inserting the value it's inserting a set of spaces and tabs (even though tabs are supposed to be replaced with spaces).

This only seems to happen when I have ReSharper enabled.  If I susspend ReShraper the auto complete works as expected.  Does anyone have any ideas why this behavior would start happening?  It was functioning just fine a couple of days ago and I haven't adjusted any settings recently.

9 comments
Comment actions Permalink

Hello Bryce,

 

thank you for the feedback.
Could you please provide screencast demonstrating the problem (e.g. using this tool).
By the way, is the following option enabled - ReSharper | Options | Environment | Editor | Visual Studio Features | Merge Visual Studio light bulb actions into ReSharper action indicator?
Thank you.

0
Comment actions Permalink

Please also specify the ReSharper version you are using.

Thanks.

0
Comment actions Permalink

Here's the behavior in action.

 

The version I have installed is 2019.2.3.  I do not see the option listed that you are inquiring about.  (Honestly I do not see any section titled "Visual Studio Features" anywhere under the Editor section.

0
Comment actions Permalink

Hello Bryce,

 

thank you for the provided info.

Could you please disable ReSharper | Options | Environment | General | Read solution model directly and check if it helps.

Please let me know about the results.

Thank you.

0
Comment actions Permalink

Angelina,

That seems to have done the trick; I also noticed that that this seems to only affect the projects that I have checked out from TFS not any of the others.  Is that related or am I imagining this?

Thanks

0
Comment actions Permalink

Hello Bryce,

 

Could you please try this private build with enabled "Read solution model directly and check if it works for you?

Thank you.

0
Comment actions Permalink

Thanks Angelina,

 

I've installed that and it appears to continue to work as desired.  Even after re-enabling the option.

 

Thank you,

Bryce

0
Comment actions Permalink

Thank you for letting me know, Bryce.

 

The fix will be included in the upcoming ReSharper 2019.3.2.

Thank  you.

0
Comment actions Permalink

Awesome, thanks Angelina I look forward to the next version then. :)

0

Please sign in to leave a comment.