R# 2019.3 regression: Code Cleanup won't run

Completed

After upgrading to R# 2019.3 Code Cleanup does nothing any more. No matter how I call it (via menu or shortcut or solution explorer), it doesn't change the code.

4 comments
Comment actions Permalink

Hello Mathias,

 

thank you for the feedback.

Is the problem reproduced in some specific solution or in a newly created also?

Could you please run Visual Studio with the following command line: 'devenv /ReSharper.LogFile c:\log\resharper.log /ReSharper.LogLevel Verbose', reproduce the issue and send us a corresponding 'resharper_log.txt' file. You can share it privately via "Submit a request" form at the top of the page.

Thank you.

0
Comment actions Permalink

Hi Angelina,

I have the problem in new and existing solutions. I have created the log file and will share it via "Submit a request".

UPDATE: See request #2402396

0
Comment actions Permalink

I would like to add on to the issue that all "Build in" clean up actions works for me and not my custom ones.

The custom one that I created simply added one extra File Header and it does add File Header just fine but all other actions in the list will not be done. This custom clean up action used to work just fine before the update.

0
Comment actions Permalink

Hello,

 

thank you for the feedback.

We are aware of the issue - https://youtrack.jetbrains.com/issue/RSRP-477442

The fix will be included in ReSharper 2019.3.1.

Thank you.

0

Please sign in to leave a comment.