ReSharper Ultimate 2019.2.2 is slowing typing performance


I'm using Visual Studio Enterprise 2019 version 16.2.5 with ReSharper Ultimate version 2019.2.2.

While I am developing my application, the code editor has a delayed response while I am typing and pressing the shortcut keys.

I then receive this error at the top of my code editor.

After I click the Manage performance link, the Performance Manager window opened with the Extensions > Typing element highlighted and the following information:

I also noticed another error within the Extension > Unresponsive UI element:

Is there an upgrade to fix these performance issues?

Kind Regards


This is now hindering our development. I had to disable the ReSharper extension.

Please advise me what we need to do to fix this performance issue immediately!!

Kind Regards



I have the same issue posted here. 

They advised me to make a performance snapshot, but i'm not working at my code at the moment. Maybe you can do it to help Jetbrains to find the reason?

By the way, even if this message occurs it don't really hinder me. You can disable the message if you click on "Don't report this extension again".

Kind Regards



The same problem still exists with ReSharper version 2021.2.

Obviously JetBrains doesn't care at all.


Hello Steve Roetzel, Andreas Seibt, A Schloss,

Thank you for the feedback.
We are really sorry to hear that you experienced a performance issue using ReSharper.
Please refer to the following article with some suggestions and our plans on improving ReSharper performance. Maybe it can help you.

We constantly work on ReSharper performance improvement, but some problems can only be solved by taking ReSharper out of the process.
Please follow the issue to get the latest updates about the progress of moving ReSharper out of the Visual Studio process.

Also, if you have performance problems, please follow this article to collect a performance snapshot and send it to JB team. We'll investigate this issue.

Thank you.


Strangely, "ReSharper 2021.1.1 is slowing typing performance" for me even in a process where ReSharper is suspended:


Stefan Arnold Current ReSharper version is 2022.1.1, but updating won't fix the issue. The performance issue is mostly caused by high memory consumption. I've filed a bug report ( ) with quite some effort to provide dumps and logs. But JetBrains simply has stopped investigating. I assume, they are working on Visual Studio 2022 support and have no resources left, which is bad, because VS-2022 is still not useable in a professional environment. Additionally, as you can see, this issue ist already quite old and effectively nothing happend to resolve it. So don't expect too much.


A Schloss: Thanks for the update! The link to your bug report already seems outdated. To be honest, I did hardly hope that this long-standing problem (with C++ projects, in my case) would be fixed in the near future. Just wanted to share my surprise that ReSharper can slow down Visual Studio even when it's suspended.


Please sign in to leave a comment.