Issues with ReSharper 2019.2 in Visual Studio 2015

I recently updated to ReSharper 2019.2. I use ReSharper and ReSharper C++, in Visual Studio 2015 and 2017. I have not observed any issues with 2019.2 in Visual Studio 2017.

However, in Visual Studio 2015, where I use ReSharper C++, several things are no longer working.

Most importantly, "Rich Text Navigation" is no longer working. I have tried disabling and re-enabling it, clearing caches, even fully re-installing ReSharper; with no success.

But additionally, I no longer see any ReSharper entries in the right-click context menu (when a type or method is selected), entries such as "Find Usages" (and as far as I can tell, all ReSharper functions) are no longer present.

As I said, disable/re-enable, cache clearing, full re-installs, are not solving my problem.

Over the years, I have come to rely on ReSharper, and the lack of these functions is proving to be extremely counter-productive. Any help would be greatly appreciated.

7 comments
Comment actions Permalink

Hello!

So basically ReSharper stopped working in VS2015 at all? Does anything work, e.g. global navigation or code inspections? Does this happen on all solutions?

Could you please run VS2015 with "/ReSharper.LogLevel Verbose /ReSharper.LogFile c:/path/to/log/file", open your solution, and attach the resulting log file to https://youtrack.jetbrains.com/issue/RSCPP-27436

Thanks!

0
Comment actions Permalink

Code inspections seemed fine, but navigation was not working.

I only use Visual Studio 2015 with this 1 C++ project, all other projects have been moved to Visual Studio 2017. And I'm afraid I didn't try with a blank/new project.

The thing is, ReSharper C++ 2019.1.3 was working perfectly fine, with this project, nothing major changed in the project, only ReSharper C++ was upgraded to 2019.2, and everything stopped working.

Since my original post, I uninstalled ReSharper 2019.2, and re-installed 2019.1.3, and that no longer worked either!

I've now uninstalled everything ReSharper related, and manually cleaned all references to everything JetBrains-related from Windows. I will attempt to re-install 2019.2 now. If I still have issues, I'll happily run the log output and attach it to the issue.

But if everything works, I'll add a comment here, to let you know.

Thanks for getting back to me, in any case.

0
Comment actions Permalink

Having uninstalled ReSharper from both VS2015 and VS2017, and manually deleted all JetBrains references (AppData folders, Registry entries, etc), I have re-installed ReSharper 2019.2, and everything is now working in VS2015.

So my issue is now fixed, though it was somewhat "painful". Therefore I guess there's little point me providing the log output. It would appear that the upgrade process is what failed, rather than there being an issue with 2019.2 itself.

I don't know if anything will help, but I can tell you that:

  • I'm running Windows 10 Professional x64 (installed as 1809, but upgraded to 1903)
  • Visual Studio 2015 is Professional with Update 3 (installed as that, and not updated)
  • My initially installed ReSharper would have been 2018.3, and it's been upgraded with each release since (today was the first clean install since 2018.3)
  • I have a ReSharper Ultimate license, but have only ever installed ReSharper and ReSharper C++
  • I have noticed with past ReSharper C++ updates, that code inspections were wrong after an update (usually with complex macros, or deeply nested includes), but clearing caches always fixed it

If I can provide any additional information, I'm happy to do so. But I no longer have a reproducible issue.

Thanks again, for trying to help out.

0
Comment actions Permalink

I see, thanks a lot for the detailed info. Please let us know if this issue happens again.

0
Comment actions Permalink

Today, I updated to ReSharper 2019.2.2 and the issue I described above (smart navigation not working in Visual Studio 2015) has re-occurred.

Rather than going through all the uninstalling/cleaning, that fixed the issue before, I am hoping a more "permanent" fix can be found.

I have a ReSharper log file ready to upload, but the issue created before appears to have been closed.

0
Comment actions Permalink

I've recreated the issue - https://youtrack.jetbrains.com/issue/RSCPP-27521, please attach the log there. Thanks!

0
Comment actions Permalink

I've uploaded the log file,

Thanks.

0

Please sign in to leave a comment.