Cannot detect C++17 syntax with Unreal Engine 4

When I enable C++17 through Unreal's Build.cs(CppStandard = CppStandardVersion.Cpp17) and Target.cs, ReSharper C++ cannot detect C++17 is enabled.

Since Unreal uses UBT, build succeeds anyway, but this is kinda annoying.

Any idea to solve this problem?

2 comments
Comment actions Permalink

Hello,

Please try setting "NMake | Additional Options" to "/std:c++17" in your project properties.

0
Comment actions Permalink

Thanks, works like a charm!

And sadly, I dug up Unreal's VSProject.cs but there's no code about writing NMake.AdditionalOptions.

So mamually adding /std:c++17 is the best option now, I guess.

0

Please sign in to leave a comment.