Parameter Name Hints: Color Scheme is Thrown Off

Answered

Using latest version of VS2019 and R#, the color of the parameter name tags that appear are hard to read. I imagine this is due to an extension that I have from MS called "Color Theme Editor for Visual Studio 2019" that I used to apply a custom Dracula theme. I need to know what the specific color element names are so that I can update them and they won't look so bad (see screenshot below):

Can anyone help with this?

 

P.S. If it helps to re-create the issue, here's the .vstheme file to import via the color extension: https://gist.github.com/mzhukovs/438f4798cef3caf61549892331fbb544

15 comments
Comment actions Permalink

Hello!

 

Thank you for contacting us.

Could you please try configuring color using VS Tools | Options | Environment | Fonts and Colors | Display Items: ReSharper Parameter Name Hint.

Thank you.

0
Comment actions Permalink

That did the trick, thanks Angelina!!

0
Comment actions Permalink

Just ran into this myself, I've run into it before but decided not to look into why and just chose a different theme those times. Could you please make it respect the "default" value which is defined by the theme? Your users shouldn't have to go and convert the default value into a custom value every time we feel like trying a new theme.

0
Comment actions Permalink

Hello Adran,

 

Could you please specify for what VS theme you've experienced problems with parameter hint color? And what is your ReSharpe version?

Thank you.

0
Comment actions Permalink

Literally any theme from here: https://marketplace.visualstudio.com/search?target=VS&category=Tools&vsVersion=&subCategory=Themes

But right now I'm using this one: https://marketplace.visualstudio.com/items?itemName=kaos.nightowl

Tested on VS 16.2.5 (R# 2019.1.1 and R# 2019.2.2), and VS 16.3.1 (R# 2019.2.2), happening on all those combinations.

Without setting a custom value:

With a custom colour set manually:

0
Comment actions Permalink

I'm just running into the very same problem Adrian described above. Unfortunately his solution doesn't work for me, as with the actual verson of ReSharper (2019.3.20191207.71323) on Visual Studio 2019 (16.4.29613.14) the Color ReSharper Parameter Name Hint simply doesn't appear anymore. The whole list seems to be reorganized (several of the colors to be found language specific now, e.g. ReSharper C# Parameter Identifier), but ReSharper Parameter Name Hint I can't find anywhere...

0
Comment actions Permalink

Hello Peter,

 

Indeed we've changed entries for code highlightings.

Please try configuring "ReSharper Inlay Hint". Hope it helps.

Thank you.

0
Comment actions Permalink

Hello Angelina,

great, that's it!

Thank's a lot.

0
Comment actions Permalink

It's "ReSharper Inlay Hint"

0
Comment actions Permalink

How can I control the colors in the similar Tools -> Debugger -> Editor Integration -> Inlay Editor Hints

 

When "show local variables values" is selected, the colors are totally off when debugging, and cannot be controlled by "Resharper Inlay Hint" discussed above

0
Comment actions Permalink

Hello @Mom, 

 

Sorry for the delay in responding.

Please use "ReSharper Debugger DataTip" for that purpose.

Thank you.

0
Comment actions Permalink

Do you know why Visual Studio/ReSharper can't just use the "default" value for these settings? Why do I as a customer have to go in and set the default value as a "custom" value for the settings to take? Isn't this something that your extension should handle?

1
Comment actions Permalink

The Resharper color options aren't appearing at all at my machine.

0
Comment actions Permalink

Hello Arnoldp,

 

VS sometimes needs it's cache of fonts and colours to be updated forcibly. Please refer to the following help article - https://resharper-support.jetbrains.com/hc/en-us/articles/206546479.

Thank you.

0
Comment actions Permalink

It's really frustrating having to set this every so often. Can you please fix the setting instead so that it actually applies the set automatic values that come from the theme?

0

Please sign in to leave a comment.