Extract interface missing when resharper is enabled

Answered

I am using VS 2017 latest version and when I press Ctrl + . (Quick actions) menu is opened Extract interface option is missing. I disabled Resharper restarted VS and Extract Interface appears there. When I enable Resharper again the selection is gone.

Why is that happening?

 

Thanks in advance

8 comments
Comment actions Permalink

Hello!

 

Please try disabling ReSharper | Options | Code Inspection | Settings | Do not show VS bulb.

Hope it helps.

Thank you

0
Comment actions Permalink

Thank you. I searched the entire google but couldn't find anything

0
Comment actions Permalink

Is there any other workaround. I need these options from VS Bulb. I remember it used to work having both things (VS Bulb and Extract Interface)

0
Comment actions Permalink

Thanks Angelina this worked perfectly.

0
Comment actions Permalink

I dont see such an option in latest resharper. Missing interface is not shown in light bulb. (VS2019, Resharper Ultimate 2020.1.2)

0
Comment actions Permalink

Hello Antonis Panagi

 

Please try ReSharper | Options | Environment | Editor | Visual Studio Features | Hide Visual Studio light bulb.

Thank you.

0
Comment actions Permalink

There is no such option in 2021.3

 
0
Comment actions Permalink

@Zed, the analog of this option is "Hide Visual Studio Quick Action icons in the left editor margin". Please let me know if you have any questions.

0

Please sign in to leave a comment.