Resharper block selection hangs Visual Studio 2019


NOTE: I tried to report this through the Resharper Extension Feedback mechanism of Visual Studio, but every time I try to hit "Submit" the dialog tells me "Internal Server Error" so I cannot report it.  So I have attached the Environment Info file here

I've been seeing this problem ever since I upgraded to version 16.0.3 of Visual Studio 2019. However I have upgraded a couple of times since then and it still happens..

It only happens when I do a block text selection (i.e. I hold down the ALT key and try to select text vertically as well as horizontally) AND Resharper is enabled

It basically locks up the entire user interface. The screen fades (showing it is "busy") and it never comes back. I have to kill VS2019 in the Task Manager.

I initially reported this to Microsoft. They had me send them a PerfView file and from it they reported that the CPU was spending most of its time in the Resharper extension.  So now I am reporting it to you.

It usually doesn't happen right away. I usually must be editing files for a while (usually) before block selection will lock things up. Also I tend to have to scroll down several row in block selection to trigger it. And it seems to be more likely to happen when the file is big

Today I was able to make it happen as soon as I opened Visual Studio. Every time. So I tried suspending Resharper and *then* doing a block selection. In that case, no hang occurred. Then I resumed Resharper and did another block selection and it locked things up again.

I do have Visual Assist and other extensions but even after disabling those it still happens.  It only occurs when Resharper is enabled.

Here is the contents of my Environment File:

Visual Studio:
Version: 16.1.29001.49
Sub Edition: None

Installed Products:
AzureAppServiceToolsPackage 16.1.429.50124
CMakeNativePackage 1.0
CommonAzureToolsPackage 1.10
DebugAdapterHostPackage 1.0
EditorconfigResourcePackage 1.0
EFCorePowerToolsPackage 1.0
ExternalBuildFrameworkPackage 1.0
GoogleTestExtensionOptionsPage 1.0
KofePackagePackage 1.0
Microsoft Visual Basic 3.1.1-beta4-19281-06+58a4b1e79aea28115e66b06f850c83a3f1fcb6d3
Microsoft Visual C# 3.1.1-beta4-19281-06+58a4b1e79aea28115e66b06f850c83a3f1fcb6d3
Microsoft Visual C++
Microsoft Visual F# 16.1.0-beta.19253.3+42526fe359672a05fd562dc16a91a43d0fe047a7
MIDebugPackagePackage 1.0
NuGetPackage 5.1.0
ProjectServicesPackage 1.0
ResourcePackage 1.0
SqlCeToolboxPackage 4.7
StopOnFirstBuildErrorPackage 1.0
Team Explorer
Telerik WPF VSExtensions 2019.2.503.3
VCManagedPackage 1.0
VCWizardsPackage 1.0
Visual Assist 10.9.2333.0
VisualCommanderPackage 3.1.1
WebProjectPackage 16.1.429.50124

.NET Framework:
Versions: 3.5.0;4.6.2


Hello Joe!


Thank you for the feedback.

Could you please collect dump as described in the following article.

You can share it using 'Submit a request' form at the top of the page.

Thanks in advance.


OK, I managed to make it happen today and captured the dump as per the instructions.  I will submit a request now


Please try installing the latest ReSharper 2019.1.2 and check if the problem is still reproduced.
Thank you.


Hi Angelina,

I did upgrade to that version yesterday.  I will try to reproduce it again.  Sometimes it can take a full day of editing for me to trigger it so I might be a while responding but I will reply back here if enough time goes by and I think it is fixed


Well 5 days after installing 2019.1.2 and I have been unable to make it happen.  I would appear that update fixed it.


Hello Joe!


Thank you for the feedback. Glad to know it worked for you.


Please sign in to leave a comment.