Disabling the action bar indicator isn't fully respected

I disabled environment> editor> action indicator> enable action bar.

Still, there are small x's in a circles with an up or down arrow pointing to the next hint.

I had to disable code inspection> settings> general> enable code analysis, to get rid of that. The price was to lose resharper text coloring.

8 comments

Hello!

Please attach a screenshot - I'm not sure what you mean.

If you mean navigation gutter icons, you can disable them via "Code Editing | C++ | Inspections | Show gutter icons".

Thanks!

 

0

I'm referring to this litter:

0

Please set "Code Editing | C++ | Inspections | Show gutter icons" to "None". There are shortcuts for different navigation actions - e.g. go to definition, base method, derived class and so on.

0

It was already set to none; I checked it the first time you mentioned it.

It mostly gives me tips such as a local variable hiding an outer variable with the same name, navigate.

0

I see - these icons also provide navigation for some inspections, and in this case the setting is not used. We'll fix this, thanks!

0

You can turn off this inspection for now if you don't want to see the icons.

0

Thanks, as I said initially, that's what I did.

0

Sorry, I was hoping that disabling the specific inspection will help (as opposed to disabling all the inspections), but that does not seem to be the case - we'll fix this too. Please update to 2019.1.2 when it's released, should be out in a week or two.

0

Please sign in to leave a comment.