Using ReSharper and CodeLens in VS 2019

Answered

Can anyone tell me how to enable CodeLens when I have ReSharper also enabled.  I'm using VS 2019 (16.0.3) and ReSharper 2019.1 and every time I go to Tools > Options > Text Editor > All Languages > CodeLens, the "Enable CodeLens" checkbox is unticked.  Ticking it makes no difference as every time I go back in, it is unticked again.  Removing ReSharper solves this issue.

Is this a known issue or is this desired functionality?

Stephen

3 comments
Comment actions Permalink

CodeLens works fine for me - VS2019 Pro (16.0.3) with R# 2019.1, so I doubt it's the desired functionality. :)

0
Comment actions Permalink

@Stephen, please check which option is selected for "Disable CodeLens for all languages" here ReSharper | Options | Environment | Performance Guide.

2
Comment actions Permalink

Success, this worked perfectly, thanks!

0

Please sign in to leave a comment.