Optimize 'using' directives places System namespaces on top



This seems (and feels) like a simple issue, but I can't find the solution. When running Code Cleanup, with "Optimize 'using' directives" enabled, the System namespaces are placed on top and not sorted alphabetically with the rest.

I've searched for an option somewhere to change this behavior, but I only found a setting in Visual Studio itself "Place 'System' directives first when sorting usings", but enabling or disabling this option doesn't have any effect on the code cleanup.

Is it possible to change this behavior? And if so, can you please let me know where?


- Visual Studio 2019 Pro

- ReSharper Ultimate 2018.3.4


Kind Regards,



Comment actions Permalink
Official comment

Hello Geert-Jan!


Corresponding option has been introduced in ReSharper 2019.1 EAP, you are welcome to try it - https://www.jetbrains.com/resharper/eap/.

It's ReSharper | Options | Code Editing | C# | Code Style | Place 'System' and 'Windows' namespaces first.

Thank you.

Comment actions Permalink

Hi Angelina,


That seems to solve the problem. Thanks!






Please sign in to leave a comment.