Issue with jumping to bookmark 0

Completed

I am on a fresh install of of Visual Studio Professional 2017 15.9.0 and ReSharper Ultimate 2018.2.3. Using the set bookmark shortcut CTRL+SHIFT+# works as expected, I can set bookmarks 0-9, but for some reason the jump to bookmark shortcut CTRL+# only works for shortcuts 1-9. Pressing CTRL+0 never works.

I tried going to ReSharper -> Options -> Keyboard & Menus, setting keyboard shortcuts to 'None' and applying, then setting them back to 'Visual Studio' and applying. The problem persists. Any idea how I could further troubleshoot why that one specific shortcut isn't working?

3 comments
Comment actions Permalink

Hello Patrick!

 

Thank you for contacting us.

Could you please try assigning 'ReSharper_BookmarksToggleBookmark0' command to Ctrl+0 shortcut in VS Tools | Options | Environment | Keyboard and check if it helps.

Thank you.

0
Comment actions Permalink

Hi Angelina, thanks for the comment. I think I accidently misstated my question, my issue was with the CTRL+SHIFT+0 keyboard shortcut not working, not CTRL+0. I just went into VS Tools | Options | Environment | Keyboard and found that Visual Studio won't even recognize my input of CTRL+SHIFT+0.

I just searched as to why that specific input would not register in Windows, and found a solution. It appears the Windows Switch Keyboard Layout setting was conflicting with that shortcut. Here are the steps I followed to fix it should anyone find this question in the future:

https://support.microsoft.com/en-us/help/967893/input-method-editor-keyboard-shortcut-ctrl-shift-0-switches-the-input

0
Comment actions Permalink

 

Thank you for the provided info, Patrick.

0

Please sign in to leave a comment.