Autocomplete not working in C++/CLI Class within Unmanaged Project

As of  Resharper 2018.2, there's supposed to be some limited support for C++/CLI. Despite this, autocomplete just downright isn't working in my C++/CLI document. I can't get the window to pop up no matter what. If I swap over to a pure C++ file within the project, everything works fine there. It's only the C++/CLI document it doesn't work. I'm assuming there's some form of logs I need to submit?

 

This specific class is set to use CLR while the containing project isn't. Could this have to do with it?

1 comment

Hello!

Do you mean that the file is set to compile with /clr, but the containing project is not? If so, this is probably the source of the problem, this is tracked in https://youtrack.jetbrains.com/issue/RSCPP-23420.

You can turn off the "Enable C++/CLI support" option, so that R++  fall backs to Visual Studion completion in C++/CLI files.

0

Please sign in to leave a comment.