Right Click on Object / Variable Causes VS2017 to freeze

On regular occasions, right clicking on an object or variable to bring up the context menu causes VS2017 to freeze for 30s+. It eventually unfreezes itself and right clicking on the same object / variable then instantly brings up the menu.

I have tried disabling Resharper and I don't suffer this issue, it only occurs with Resharper is activated.

This doesn't occur every time and there doesn't seem to be any obvious pattern. I have also tried clearing Resharper cache and resetting all settings to factory settings.

I am using Resharper Version: 2018.2.1 and VS2017 15.6.7 (I can't upgrade to a newer version as I am using Cuda 9.1 and it doesn't support anything newer than this).

10 comments

Hello,

It would be great if you could collect and send us a performance trace which captures the lag - see https://resharper-support.jetbrains.com/hc/en-us/articles/210652849-Collect-Timeline-performance-snapshot-in-Visual-Studio about how to do that.

Thanks a lot!

0

Submitted as requested.

 

Edit : I have tried to submit several times, the files are uploaded, but ultimately results in a "Failed to upload some of the attachments" error.

0

Could you please upload the trace via https://uploads.services.jetbrains.com/ and let us know the exact name?

0

I'm not 100% sure what's happening here, but one of the functions on the call stack during a UI hang is Intel.CommonTools.IntelCommonPkg.GetFunctionAtCursor(). Do you by chance have any VS extension from Intel installed? If you do, please try disabling them temporarily and check if the problem goes away.

0

I have Intel Parallel Studio XE 2018 installed (which contains a package of Intel products). I have had versions of Intel Parallel Studio and and Resharper installed for past couple of years without issue and as stated previously when I suspend just Resharper I don't suffer the UI hang.

I will try to your suggestion and report back.

0

I am currently travelling so I haven't been able to do as much testing as I would have liked, but it appears that I when remove the Intel Parallel Studio integration, I don't been suffer the freezing. I have tried upgrading to XE 2019 that has just been released and the issue returns.

Therefore, I would tentatively conclude there is some issue between Resharper and Intel's VS integration that is causing this lock-up problem.

It is quite a pain for me, as really need the Intel integration for my current project and obviously I love ReSharper functionality.

0

Could you please also try disabling Visual Studio IntelliSense completely if it's an option for you? To do that set "Disable Database" to "True" in Tools | Options | Text Editor | C/C++ | Advanced | Browsing/Navigation. If this does not help then unfortunately you'll have to disable either the Intel extension or ReSharper.

0

Thanks for letting us know! If you miss some functionality from IntelilSense, please tell us, and we'll do our best to catch up.

0

Please sign in to leave a comment.