C++ project's "Command Arguments" now excluded during unit testing

Because my .exe is a cli program, it expects "--test" to be passed as the first argument to enable testing mode. I have "--test" in my project property's "Command Arguments." This used to work, in that invocations would be like

my.exe --test --gtest_list_tests

as described here, which worked well. But now it just runs

my.exe --gtest_list_tests

Is there a way to use the old behavior?

2 comments
Comment actions Permalink

Hello,

You need to enable the "Use command-line arguments" option in the "ReSharper | Options | Tools | Unit Testing | C++ Tests" options page. We'll update the help topic, sorry.

0
Comment actions Permalink

That fixed it. Thanks.

0

Please sign in to leave a comment.