Resharper doesn't work for header files without extension

Hello!

I am trying to use Resharper C++ for Open Scene Graph project. Most of header files in this project don't have any extensions. And as a result all features of Resharper are disabled for these files in the editor.

Tried to set Options->Text Editor->Map extensionless file to: Microsoft Visual C++ in MSVC but this doesn't help.

Using Resharper C++ 2018.1.3 in MSVC 2017.

How to enable Resharper C++ features for header files without extensions?

Regards,
Andrey.

 

3 comments
Comment actions Permalink

Hello,

Sorry, R++ at the moment does not support files that don't have an extension and are included into the solution. I believe it's a limitation of the ReSharper platform, which uses the extension to determine the file type. We'll consider how we can improve this situation.

However, If a header is not a part of the solution but is included into a .cpp file, R++ features should work inside it.

0
Comment actions Permalink

Hello Igor, thanks for reply.

Its a pity that there is such limitation of the ReSharper platform. Also if Open Scene Graph is used as third party library the headers without extension are processed correctly. Is there a bug tracker issue for this problem?

Do you know if CLion also has such limitation? I want to try it for OSG because it uses CMake for building.

 

0
Comment actions Permalink

I've created a request - https://youtrack.jetbrains.com/issue/RSCPP-22903.

I've not tried CLion with OSG myself, but I'd expect it to support headers without an extension if they are mentioned in the CMake script.

0

Please sign in to leave a comment.