Error launching Unit Test Debugger Windows 10

Hi, 

I'm getting the error, when trying to debug any test via the resharper unit test explorer. 

This happens on both brand new created solutions and current solutions.

----------------------------------------

'Cannot launch debugger'

Error code 89710016

----------------------------------------

Steps to reproduce, create a new test project in Visual studio

Install Nunit via nuget

Create a quick test

attempt to debug

***Note, running a test is fine, it's only the debugger that fails.

 

OS Windows 10 64 bit

Visual Studio 2017 Professional 15.7.5

ReSharper Ultimate 2017.2.2

 

Currently I'm the only one in the office suffering from this, but I am the only person on Windows 10, no one else has been upgraded yet.

The only difference between mine and other users is Windows 10, but as it's going to be company policy to update everyone to Windows 10, I can't be rolled back.

 

Any ideas?

I've looked at other instance of this issue from years ago, but nothing really matches what I'm seeing now

2 comments
Comment actions Permalink

Hello Ben!

 

Thank you for contacting us.

Could you please specify which "Platform" is selected for the project with Unit Tests in Configuration Manager. If it is "Any CPU" please try changing it to "x86" value.

Thank you.

0
Comment actions Permalink

Hi,

 

I was using any CPU, to debug switching to x86 fixed the issue.

 

Any reason why this doesn't happen on Windows 7 64 bit? 

0

Please sign in to leave a comment.