Require a name for tuple fields



Is it possible to require (error/warning) a name for tuple fields? For instance, the method returns a tuple, so without a name for tuple fields the code will use `Item1`, `Item2` etc, as a result of the code very quickly becomes a mess.


  foreach ((SubBeam, List<BeamGainMeasurement>) subBeam in preProcessor.FindUplinkSubBeams(outputData.LinkBudgetScenario, downlinkId))


this version is much better


  foreach ((SubBeam SubBeam, List<BeamGainMeasurement> Measurements) subBeam in preProcessor.FindUplinkSubBeams(outputData.LinkBudgetScenario, downlinkId))





1 comment
Comment actions Permalink

Hello Sergey!


Thank you for contacting us.

I've filed corresponding feature request -

You are welcome to comment or vote for it.

Thank you.


Please sign in to leave a comment.