Resharper Continuous testing session feature not showing in options

Completed

I am having an issue where there is no option to start a continuous testing session... the option literally does not exist in the unit test menu/tab. I have tried to repair the resharper download and it is still not there. Did they take it out? I haven't used resharper in a while now.

11 comments
Comment actions Permalink

Hello!

 

Thank you for contacting us.

Could you please let us know if there's dotCover tool installed?

Thank you.

0
Comment actions Permalink

Its working fine now thanks for the reply

0
Comment actions Permalink

Hi,

I'm having the same issue. Resharper installed, along with dotCover.

VS toolbar -> ReSharper -> UnitTests -> <no "Continuous testing" related menu items>

In the Unit Test Sessions screen I can only see "Autostart Tests on Build" options (3 of them), which is nice but not a continuous testing of course (I'd expect to have tests ran sooner in the background).

1
Comment actions Permalink

Hello Konstantin!

 

Continuous testing can be triggered either on build or save action (can be configured in ReSharper | Options | dotCover | Continuous testing) and is run automatically in background.

Please refer to the corresponding help article for more details - https://www.jetbrains.com/help/dotcover/Continuous_Testing.html.

Thank you.

0
Comment actions Permalink

Thank you Angelina,

Sorry for trouble, now it works.

0
Comment actions Permalink

Sorry to hijack, but it is kind of related...

I have recently noticed dotCover options have gone from my VS -> Resharper menu too.



In Resharper Options I do not even have any dotCover options at all, even if I use the search term "cover".. 


ReSharper | Options | [dotCover missing]

I can run the DotCover desktop app, see image below.


I have have also just downloaded the latest version of R~ and DotCover from the Jetbrains website. Still no joy.

Thanks in advance.

0
Comment actions Permalink

Hello Dibley1973,

 

Seems that you haven't selected the VS integration option for dotCover during installation.

Could you please run the installer again and check that VS integration option is on for dotCover and the VS version that you are using is selected.

Thank you.

0
Comment actions Permalink

Hi Angelina,

Thank you for your response. I will get right on it and feed back after.

BR,
Dib

0
Comment actions Permalink

Hi, I checked that option while reinstalling...

but I still do not have the option to cover tests in the resharper menu. I used to, but it disappeared at some point in the last couple of months.

BR,
Dib.

0
Comment actions Permalink

Do you have dotCover enabled in ReSharper | Options | Environment | Products and Features?

Thank you.

1
Comment actions Permalink

That will be it! It was disabled. Not sure when that happened, I don't recall disabling it but I guess I must have!

Thank you for your help.

 

0

Please sign in to leave a comment.