Naming rules for Reactive fields?
I'm doing some heavy duty development with Avalonia using the ReactiveUI Source Generators and the default Resharper naming rules are getting in the way. I have to define a field like this :
[Reactive] private ObservableCollection<string> sent_list;
and the source generator creates a public property called “Sent_list” with the necessary code attached to make it reactive. This conflicts with the standard Resharper naming conventions which want to rename it “_sentList” - a name that would cause the source generator all sorts of problems.
I could update the standard rule so that it requires all private fields to have lower case names, but it would be good if I could create a custom rule that recognises the presence of the “[Reactive]” qualifier and distinguishes between that field and standard fields. Is there any way to do this?
TIA
Martin
Please sign in to leave a comment.
Hello,
Currently, there's no such option at the moment, here's a corresponding feature request - Set up a naming convention for types or fields marked with an attribute. You are welcome to comment or vote for it.
Thank you.