AsyncIO package resolve error when installing 2016.2 EAP 1 SDK

I've just tried to install the 2016.2 EAP 1 SDK and get the following error:

Attempting to gather dependency information for package 'JetBrains.ReSharper.SDK.2016.2.20160525.124855-eap1' with respect to project 'Src\XmlDocInspections.Plugin.R20162', targeting '.NETFramework,Version=v4.5'
Attempting to resolve dependencies for package 'JetBrains.ReSharper.SDK.2016.2.20160525.124855-eap1' with DependencyBehavior 'Lowest'
Unable to find a version of 'AsyncIO' that is compatible with 'JetBrains.Platform.Core.Ide 106.0.20160525.120944-eap1 constraint: AsyncIO (= 0.1.17.1)', 'JetBrains.Platform.RdProtocol 106.0.20160525.120944-eap1 constraint: AsyncIO (= 0.1.17.1)'.

3 comments
Comment actions Permalink

Hi Ulrich!

Thanks for pointing out. Yes, it's a bug. We'll try to fix it in next EAP build.

1
Comment actions Permalink

Hi Slava,

hmm, ... now with EAP 2 I get "Unable to resolve dependency 'JetBrains.AsyncIO'. Source(s) used: 'nuget.org', 'Dev Packages (xunit)', 'Microsoft and .NET'"

 

0
Comment actions Permalink

With EAP 3 there also seems to be a problem:

Attempting to resolve dependency 'JetBrains.ReSharper.SDK.Internal (= 106.0.20160609.95932-eap3 && < 106.1.0)'.
Attempting to resolve dependency 'JetBrains.Psi.Features.src (= 106.0.20160609.91944-eap3 && < 106.1.0)'.
Unable to resolve dependency 'JetBrains.Psi.Features.src (= 106.0.20160609.91944-eap3 && < 106.1.0)'.
0

Please sign in to leave a comment.