Turning Off symbolsource.org

Hello Community,

I am having some problems with source symbols.  I have everything configured exactly how I want it with dotPeek.  In fact, everything works exactly how I want it.  However, I have been spending the morning trying to figure out why my symbols are not downloading properly and matching up with the decompiled source from dotPeek.

It turns out that in my case, there is a listing in symbolsource.org for my assembly (System.Composition.Convention), which apparently is version mismatched from my generated pdb file from dotPeek.  It seems as if both dotPeek and the symbolsource.org download their own version.  The symbolsource.org version is dated from last October, while dotPeek's is from today (as expected).  Unfortunately it does seem that the symbolsource is being used, and the symbols do not load properly when I view the source.

It would be great to know how I can turn this off and use dotPeek exclusively.  I have unchecked "Enable source server support" in my Debugging options and it seems as if that doesn't do the trick.

Thank you,

Michael

3 comments
Comment actions Permalink

OK looking into this more, this appears that it has something to do with shadow assemblies for unit testing.  If I turn off shadow assemblies, then everything works well.  However, if shadow assemblies are on, then something doesn't quite resolve correctly with the assembly in memory vs. the assembly being used to generate the pdb file.  Perhaps this is a bug?

Additionally, I was able to turn off symbolsource.org by unchecking "Allow downloading from remote locations" under External Sources.  This is not obvious that it means symbolsource.org, and it would be nice to maybe update the UI with a "?" indicator explaining this, so that typing "symbolsource" in the Options search turns this up as a result.

0
Comment actions Permalink

Well never mind, then.  This appears to be a temporary problem somewhere on my end.  I just tried to make a very simple replication of the issue with a simple project, but could not, and then went into the main project and it seems to be working as expected now.

The one thing I will add is that I was getting errors in dotPeek during debug session initialization that said it couldn't (automatically) load the pdb files.  Here is a screenshot of these messages:

What I was doing was deleting .pdb and decompiled sources folders, launching debug session, and then noticing that the pdb/symbols were not automatically loaded.  I then loaded them, which would load them in from dotPeek.  However, they would be in this funky state as described above.

So it appears that the core of the issue is that dotPeek wasn't loading the symbols/decompiled automatically for some reason after deleting them from disk.  If I run into this issue again I will be sure to update here.

Thank you,

Michael

0
Comment actions Permalink

FWIW, I am having problems again with symbols and decompiled code, and the wrong symbol locations being provided by R#/dotPeek.  I have created a issue (along with video in comments) of this in action:

https://youtrack.jetbrains.com/issue/DOTP-7318

0

Please sign in to leave a comment.