Extra Lines being inserted on completion

Completed

I've specifically set ReSharper to the code style I want, and in C# it does exactly what I ask. But I'm working on an Angular page, and in the controller.js file, ReSharper (and I've disabled it and reenabled it to make sure it was ReSharper) is taking this:

and turning it into this:

Note the amount of space. It's auto-formatting an extra line between every thing in the code.

The truly interesting part is... My ReSharper settings do NOT have 'apply code style on completion'  turned on! (see image)

Even more interesting - If I check that box, and click "Save" at the bottom of the window... It does NOT save the Apply checked status, so the next time I open the window, the box is unchecked again. In fact, it's formatting my HTML, too - in ways I didn't tell it. And I've noticed that nowhere can I get that 'Apply code style on completion' checkbox to actually save.

Further, this is with the latest version of ReSharper Ultimate, in Visual Studio 2015.

I love ReSharper, and in my C# it's a dream, but it's royally screwing up my JS. HELP!

2 comments
Comment actions Permalink

The latest EAP fixed the problem! Thanks!

0

Please sign in to leave a comment.