Need to remove click on suggestions

I need to remove the warnings/suggestions gives when clicked in the source code. Refer below image.

eg: #include suggestions.


8 comments
Comment actions Permalink

Hello,

You can hide the popup window for the current file by pressing 'Esc'. If you want to disable this feature completely, please clear the "Show the Import namespace" check box in ReSharper | Options | Code Inspection | Settings (we haven't yet updated the name of the option to reflect that it also affects C++).

We'd also like to understand why you want to disable it. Is the popup too intrusive? Does it suggest incorrect imports? Please give us some feedback so that we can improve this feature.

Thanks!

2
Comment actions Permalink

Thanks.

And this popups are so intrusive when working. And it appears all the time and also hides some code parts.
Also it saws some unwanted includes (Includes in libraries). :) Make this as optional is better. Some of my friends use this facility as a good feature.

0
Comment actions Permalink

Hi,

The problem is that it doesn't catch up the <> includes, only takes "" includes. So it suggests the include with this popup.
Is there any setting to configure this to take <> includes.

 

0
Comment actions Permalink

Hi,

Yeah I also experience this problem. Resharper does not get linked with the <> includes (Eg: #include <Sample.h>). It highlights the code in red when it can't identify <> includes. How can I make Resharper aware of the <> includes?

Thanks

0
Comment actions Permalink

Do I correctly understand that R++ inserts "" includes, but you'd prefer the same includes but in <> form?

In the 10.0.2 release if the <> is possible, then it should be always preferred to the "" form. So it means that for some reason R++ couldn't resolve the include path in <> form. Tharaka, am I right that R++ can't resolve an include directive but the code compiles? Could you help us reproduce this? It'd be great if you could send us a solution which shows the problem, and we'll try to fix it ASAP.

0
Comment actions Permalink

Yes Igor,

You have understood it correctly. This happens always. It never includes header files if the format is <>. Actually I installed Resharper recently and experienced this problem. When I changed the include format into "" it works. Code get compiled in both ways. It won't be so hard to reproduce this issue. If this doesn't reproduce with your code please let me know. I'll make a sample code and send you which works for mine. 

Thank you for you kind response. It would be great if you could fix this soon.

0
Comment actions Permalink

Tharaka,

Sure, please do! This is probably some corner case in interfacing with Visual Studio's project model, but we treat this kind of issues as showstoppers and I don't think we've seen any since the last release. So if you would be able to help us reproduce it, that would be just great.

Thanks!

0
Comment actions Permalink

Is this still the way to disable these popups? I have unchecked the "Show the Import namespace" option however they still show up. Very annoying, especially since they're just wrong.

1

Please sign in to leave a comment.