Resharper Completion Behavior vs Visual Studio built in behavior

Answered

This is going to be tricky to describe but here goes...

Using VS 2015/C# with no Resharper I can type this (exact characters)

TimeSpan timelength = times.

The IDE will fill in this as the auto completion var timelenth = TimeSpan.  and then list members for timespan. I've gotten so used to this for auto completion that Resharper is throwing me for a loop!

Now when I type that same thing in with Resharper enabled I get this: TimeSpan t = TimeSpan.MaxValue. and the IDE will auto list different members. 

Other types display similar behavior.  

I'm not sure what setting to turn off to make this default back to what I consider normal. I've tried fiddling with lots of options, even tried to select Visual Studio on the general IntelliSense tab - but that does not cause default behavior.

What can I do to continue using most of Resharper but disable this one bit?

 

1 comment
Comment actions Permalink

Ug, found it right after I typed that... I'll post incase this helps someone else.

 

Resharper->Options->IntelliSense->Completion Behavior->"Smart Behavior in basic completion: NONE

not sure what else I turned off but this seems to fix the above situation.

0

Please sign in to leave a comment.