Cannot set keyboard shortcuts

When I attempt to start VS.NET 2003 I get the following ReSharper error:

Canot set keyboard shortcuts. Please change the keyboard mapping scheme
using Tools|Options|Environment|Keyboard settings and activate ReSharper
again.

Change the scheme to what?

Thanks,

Oskar Austegard


11 comments

Oskar,

you need to do the following:
1) Go to the Tools|Options|Environment|Keyboard settings
2) Choose 'Save as' and enter a name for the scheme being saved (e.g.,
"ReSharper"). This is what we (perhaps poorly) called
'change the keyboard mapping scheme'.
3) Restart VS

After that ReSharper will be able to set its keyboard shortcuts
programmatically.

"Oskar Austegard" <oskara@mominc.com.nospam> wrote in message
news:c10sj1$nd7$1@is.intellij.net...

When I attempt to start VS.NET 2003 I get the following ReSharper error:

>

Canot set keyboard shortcuts. Please change the keyboard mapping scheme
using Tools|Options|Environment|Keyboard settings and activate ReSharper
again.

>

Change the scheme to what?

>

Thanks,

>

Oskar Austegard

>
>


0

Same Problem here;
i have installe ReSharper on two Installations of VS.NET and on both
systems, i get the DialogBox.
Update to #65 doesn't solve the problem ...
The Keyboard-Settings were saved to multible names (including "ReSharper");
nothing helps ...


"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im Newsbeitrag
news:c11sac$v75$1@is.intellij.net...

Oskar,

>

you need to do the following:
1) Go to the Tools|Options|Environment|Keyboard settings
2) Choose 'Save as' and enter a name for the scheme being saved (e.g.,
"ReSharper"). This is what we (perhaps poorly) called
'change the keyboard mapping scheme'.
3) Restart VS

>

After that ReSharper will be able to set its keyboard shortcuts
programmatically.

>

"Oskar Austegard" <oskara@mominc.com.nospam> wrote in message
news:c10sj1$nd7$1@is.intellij.net...

When I attempt to start VS.NET 2003 I get the following ReSharper error:

>

Canot set keyboard shortcuts. Please change the keyboard mapping scheme
using Tools|Options|Environment|Keyboard settings and activate ReSharper
again.

>

Change the scheme to what?

>

Thanks,

>

Oskar Austegard

>
>

>
>


0

Hi,

could you please try to set a shortcut for your keyboard scheme manually
(via the same Tools|Options|Environment|Keyboard)?.
Please let us know if you can. We are investigating this problem further.

"SThorin" <stm@estos.de> wrote in message
news:c12fhu$7mv$1@is.intellij.net...

Same Problem here;
i have installe ReSharper on two Installations of VS.NET and on both
systems, i get the DialogBox.
Update to #65 doesn't solve the problem ...
The Keyboard-Settings were saved to multible names (including

"ReSharper");

nothing helps ...

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c11sac$v75$1@is.intellij.net...

Oskar,

>

you need to do the following:
1) Go to the Tools|Options|Environment|Keyboard settings
2) Choose 'Save as' and enter a name for the scheme being saved (e.g.,
"ReSharper"). This is what we (perhaps poorly) called
'change the keyboard mapping scheme'.
3) Restart VS

>

After that ReSharper will be able to set its keyboard shortcuts
programmatically.

>

"Oskar Austegard" <oskara@mominc.com.nospam> wrote in message
news:c10sj1$nd7$1@is.intellij.net...

When I attempt to start VS.NET 2003 I get the following ReSharper

error:

>

Canot set keyboard shortcuts. Please change the keyboard mapping

scheme

using Tools|Options|Environment|Keyboard settings and activate

ReSharper

again.

>

Change the scheme to what?

>

Thanks,

>

Oskar Austegard

>
>

>
>

>
>


0

I set some Shortcuts on VS - macros and it works fine.
At the top of the available functions are some "&Go To"s, "&Refactor"s and
one &Search and one &View - Entry.
By the way, i have german Keyboard-Layout ...

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im Newsbeitrag
news:c12g29$bfp$1@is.intellij.net...

Hi,

>

could you please try to set a shortcut for your keyboard scheme manually
(via the same Tools|Options|Environment|Keyboard)?.
Please let us know if you can. We are investigating this problem further.

>

"SThorin" <stm@estos.de> wrote in message
news:c12fhu$7mv$1@is.intellij.net...

Same Problem here;
i have installe ReSharper on two Installations of VS.NET and on both
systems, i get the DialogBox.
Update to #65 doesn't solve the problem ...
The Keyboard-Settings were saved to multible names (including

"ReSharper");

nothing helps ...

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c11sac$v75$1@is.intellij.net...

Oskar,

>

you need to do the following:
1) Go to the Tools|Options|Environment|Keyboard settings
2) Choose 'Save as' and enter a name for the scheme being saved (e.g.,
"ReSharper"). This is what we (perhaps poorly) called
'change the keyboard mapping scheme'.
3) Restart VS

>

After that ReSharper will be able to set its keyboard shortcuts
programmatically.

>

"Oskar Austegard" <oskara@mominc.com.nospam> wrote in message
news:c10sj1$nd7$1@is.intellij.net...

When I attempt to start VS.NET 2003 I get the following ReSharper

error:

>

Canot set keyboard shortcuts. Please change the keyboard mapping

scheme

using Tools|Options|Environment|Keyboard settings and activate

ReSharper

again.

>

Change the scheme to what?

>

Thanks,

>

Oskar Austegard

>
>

>
>

>
>

>
>


0

It seems that the problem is experienced by German users.
Could you please provide some information about your system:

1) Windows version / localization
2) VS.NET version / localization

Thanks in advance.

P.S. For now, you can set keyboard shortcuts for most frequent used
ReSharper features manually.
Do this from the same "Tools|Options|Environment|Keyboard" settings.
ReSharper commands can
easily be recognized because they all share the common prefix "ReSharper.".

"SThorin" <stm@estos.de> wrote in message
news:c12kio$ccm$1@is.intellij.net...

I set some Shortcuts on VS - macros and it works fine.
At the top of the available functions are some "&Go To"s, "&Refactor"s and
one &Search and one &View - Entry.
By the way, i have german Keyboard-Layout ...

>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c12g29$bfp$1@is.intellij.net...

Hi,

>

could you please try to set a shortcut for your keyboard scheme manually
(via the same Tools|Options|Environment|Keyboard)?.
Please let us know if you can. We are investigating this problem

further.

>

"SThorin" <stm@estos.de> wrote in message
news:c12fhu$7mv$1@is.intellij.net...

Same Problem here;
i have installe ReSharper on two Installations of VS.NET and on both
systems, i get the DialogBox.
Update to #65 doesn't solve the problem ...
The Keyboard-Settings were saved to multible names (including

"ReSharper");

nothing helps ...

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c11sac$v75$1@is.intellij.net...

Oskar,

>

you need to do the following:
1) Go to the Tools|Options|Environment|Keyboard settings
2) Choose 'Save as' and enter a name for the scheme being saved

(e.g.,

"ReSharper"). This is what we (perhaps poorly) called
'change the keyboard mapping scheme'.
3) Restart VS

>

After that ReSharper will be able to set its keyboard shortcuts
programmatically.

>

"Oskar Austegard" <oskara@mominc.com.nospam> wrote in message
news:c10sj1$nd7$1@is.intellij.net...

When I attempt to start VS.NET 2003 I get the following ReSharper

error:

>

Canot set keyboard shortcuts. Please change the keyboard mapping

scheme

using Tools|Options|Environment|Keyboard settings and activate

ReSharper

again.

>

Change the scheme to what?

>

Thanks,

>

Oskar Austegard

>
>

>
>

>
>

>
>

>
>


0

I use the following Systems:
Windows XP Professional (SR1) + VS.Net2003 EA (both german)
Windows 2000 Professional (SR3) + VS.Net2003 P (both german)

Most of the Shurtcuts are functioning anyway ...
one of the missing one is Alt+F7 ...

Tools|Options|Environment|Keyboard:
In the Line "Show commands containing" are no Commands beginning with
"ReSharper." ... ?


"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im Newsbeitrag
news:c12m9f$ooh$1@is.intellij.net...

It seems that the problem is experienced by German users.
Could you please provide some information about your system:

>

1) Windows version / localization
2) VS.NET version / localization

>

Thanks in advance.

>

P.S. For now, you can set keyboard shortcuts for most frequent used
ReSharper features manually.
Do this from the same "Tools|Options|Environment|Keyboard" settings.
ReSharper commands can
easily be recognized because they all share the common prefix

"ReSharper.".
>

"SThorin" <stm@estos.de> wrote in message
news:c12kio$ccm$1@is.intellij.net...

I set some Shortcuts on VS - macros and it works fine.
At the top of the available functions are some "&Go To"s, "&Refactor"s

and

one &Search and one &View - Entry.
By the way, i have german Keyboard-Layout ...

>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c12g29$bfp$1@is.intellij.net...

Hi,

>

could you please try to set a shortcut for your keyboard scheme

manually

(via the same Tools|Options|Environment|Keyboard)?.
Please let us know if you can. We are investigating this problem

further.

>

"SThorin" <stm@estos.de> wrote in message
news:c12fhu$7mv$1@is.intellij.net...

Same Problem here;
i have installe ReSharper on two Installations of VS.NET and on both
systems, i get the DialogBox.
Update to #65 doesn't solve the problem ...
The Keyboard-Settings were saved to multible names (including

"ReSharper");

nothing helps ...

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c11sac$v75$1@is.intellij.net...

Oskar,

>

you need to do the following:
1) Go to the Tools|Options|Environment|Keyboard settings
2) Choose 'Save as' and enter a name for the scheme being saved

(e.g.,

"ReSharper"). This is what we (perhaps poorly) called
'change the keyboard mapping scheme'.
3) Restart VS

>

After that ReSharper will be able to set its keyboard shortcuts
programmatically.

>

"Oskar Austegard" <oskara@mominc.com.nospam> wrote in message
news:c10sj1$nd7$1@is.intellij.net...

When I attempt to start VS.NET 2003 I get the following

ReSharper

error:

>

Canot set keyboard shortcuts. Please change the keyboard

mapping

scheme

using Tools|Options|Environment|Keyboard settings and activate

ReSharper

again.

>

Change the scheme to what?

>

Thanks,

>

Oskar Austegard

>
>

>
>

>
>

>
>

>
>

>
>


0

SThorin,

do you see any exceptions during VS.NET / ReSharper startup?
Please also make sure that the ReSharper is loaded (Tools|Add-in manager)
when you are looking for ReSharper commands.

Thanks for your information, we'll try ReSharper on german editions of
VS.NET.

"SThorin" <stm@estos.de> wrote in message
news:c12n5j$uvd$1@is.intellij.net...

I use the following Systems:
Windows XP Professional (SR1) + VS.Net2003 EA (both german)
Windows 2000 Professional (SR3) + VS.Net2003 P (both german)

>

Most of the Shurtcuts are functioning anyway ...
one of the missing one is Alt+F7 ...

>

Tools|Options|Environment|Keyboard:
In the Line "Show commands containing" are no Commands beginning with
"ReSharper." ... ?

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c12m9f$ooh$1@is.intellij.net...

It seems that the problem is experienced by German users.
Could you please provide some information about your system:

>

1) Windows version / localization
2) VS.NET version / localization

>

Thanks in advance.

>

P.S. For now, you can set keyboard shortcuts for most frequent used
ReSharper features manually.
Do this from the same "Tools|Options|Environment|Keyboard" settings.
ReSharper commands can
easily be recognized because they all share the common prefix

"ReSharper.".
>

"SThorin" <stm@estos.de> wrote in message
news:c12kio$ccm$1@is.intellij.net...

I set some Shortcuts on VS - macros and it works fine.
At the top of the available functions are some "&Go To"s, "&Refactor"s

and

one &Search and one &View - Entry.
By the way, i have german Keyboard-Layout ...

>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c12g29$bfp$1@is.intellij.net...

Hi,

>

could you please try to set a shortcut for your keyboard scheme

manually

(via the same Tools|Options|Environment|Keyboard)?.
Please let us know if you can. We are investigating this problem

further.

>

"SThorin" <stm@estos.de> wrote in message
news:c12fhu$7mv$1@is.intellij.net...

Same Problem here;
i have installe ReSharper on two Installations of VS.NET and on

both

systems, i get the DialogBox.
Update to #65 doesn't solve the problem ...
The Keyboard-Settings were saved to multible names (including

"ReSharper");

nothing helps ...

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c11sac$v75$1@is.intellij.net...

Oskar,

>

you need to do the following:
1) Go to the Tools|Options|Environment|Keyboard settings
2) Choose 'Save as' and enter a name for the scheme being saved

(e.g.,

"ReSharper"). This is what we (perhaps poorly) called
'change the keyboard mapping scheme'.
3) Restart VS

>

After that ReSharper will be able to set its keyboard shortcuts
programmatically.

>

"Oskar Austegard" <oskara@mominc.com.nospam> wrote in message
news:c10sj1$nd7$1@is.intellij.net...

When I attempt to start VS.NET 2003 I get the following

ReSharper

error:

>

Canot set keyboard shortcuts. Please change the keyboard

mapping

scheme

using Tools|Options|Environment|Keyboard settings and activate

ReSharper

again.

>

Change the scheme to what?

>

Thanks,

>

Oskar Austegard

>
>

>
>

>
>

>
>

>
>

>
>

>
>


0

The Add-In ist installed and worked so far (with some issues, already
discussed on other threads in this newsgroup)

I get this output in the debugger-console, when VS is opening a solution (on
stratup or
by using the "open" command):

-


System.ApplicationException: Event without adder/remover/raiser : ClearCache
in
type GC

System.ApplicationException: Event without adder/remover/raiser :
RowHeaderClick
in type DataGrid

System.ApplicationException: Event without adder/remover/raiser : NodeClick
in t
ype DataGrid

System.ApplicationException: Event without adder/remover/raiser :
ValidationEven
tHandler in type XmlTextReader

System.ApplicationException: Event without adder/remover/raiser :
InternalValida
tionEventHandler in type XmlValidatingReader

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataColumn

System.ApplicationException: Event without adder/remover/raiser :
CollectionChan
ging in type DataColumnCollection

System.ApplicationException: Event without adder/remover/raiser :
ColumnProperty
Changed in type DataColumnCollection

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataRelation

System.ApplicationException: Event without adder/remover/raiser :
CollectionChan
ging in type DataRelationCollection

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataSet

System.ApplicationException: Event without adder/remover/raiser :
DataRowCreated
in type DataSet

System.ApplicationException: Event without adder/remover/raiser :
ClearFunctionC
alled in type DataSet

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataTable

System.ApplicationException: Event without adder/remover/raiser :
DefaultAuthent
ication in type HttpApplication

System.ApplicationException: Event without adder/remover/raiser :
BeforeDoneWith
Session in type HttpContext


"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im Newsbeitrag
news:c12nln$37g$1@is.intellij.net...

SThorin,

>

do you see any exceptions during VS.NET / ReSharper startup?
Please also make sure that the ReSharper is loaded (Tools|Add-in manager)
when you are looking for ReSharper commands.

>

Thanks for your information, we'll try ReSharper on german editions of
VS.NET.

>



0

This was a bug in build 64 that caused some internal events to be viewed as
public by ReSharper (no other consequences on ReSharper from this
exceptions). The bug was fixed in build 65.

--
Andrey Simanovsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



<T-Online@T-Online.de> wrote in message news:c12tc3$eg3$1@is.intellij.net...

The Add-In ist installed and worked so far (with some issues, already
discussed on other threads in this newsgroup)

>

I get this output in the debugger-console, when VS is opening a solution

(on

stratup or
by using the "open" command):

>

------
System.ApplicationException: Event without adder/remover/raiser :

ClearCache

in
type GC

>

System.ApplicationException: Event without adder/remover/raiser :
RowHeaderClick
in type DataGrid

>

System.ApplicationException: Event without adder/remover/raiser :

NodeClick

in t
ype DataGrid

>

System.ApplicationException: Event without adder/remover/raiser :
ValidationEven
tHandler in type XmlTextReader

>

System.ApplicationException: Event without adder/remover/raiser :
InternalValida
tionEventHandler in type XmlValidatingReader

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataColumn

>

System.ApplicationException: Event without adder/remover/raiser :
CollectionChan
ging in type DataColumnCollection

>

System.ApplicationException: Event without adder/remover/raiser :
ColumnProperty
Changed in type DataColumnCollection

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataRelation

>

System.ApplicationException: Event without adder/remover/raiser :
CollectionChan
ging in type DataRelationCollection

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataSet

>

System.ApplicationException: Event without adder/remover/raiser :
DataRowCreated
in type DataSet

>

System.ApplicationException: Event without adder/remover/raiser :
ClearFunctionC
alled in type DataSet

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataTable

>

System.ApplicationException: Event without adder/remover/raiser :
DefaultAuthent
ication in type HttpApplication

>

System.ApplicationException: Event without adder/remover/raiser :
BeforeDoneWith
Session in type HttpContext

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c12nln$37g$1@is.intellij.net...

SThorin,

>

do you see any exceptions during VS.NET / ReSharper startup?
Please also make sure that the ReSharper is loaded (Tools|Add-in

manager)

when you are looking for ReSharper commands.

>

Thanks for your information, we'll try ReSharper on german editions of
VS.NET.

>

>
>
>


0

ok, second system was not up to date, sorry ... no exception on release #65
/ #66.
but the messagebox still pops up on #66.

"Andrey Simanovsky (JetBrains)" <ands@jetbrains.com> schrieb im Newsbeitrag
news:c12upf$p0h$1@is.intellij.net...

This was a bug in build 64 that caused some internal events to be viewed

as

public by ReSharper (no other consequences on ReSharper from this
exceptions). The bug was fixed in build 65.

>

--
Andrey Simanovsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>


0

i see, second system was not up to date ... with build #65, no exceptions
are visible ...

"Andrey Simanovsky (JetBrains)" <ands@jetbrains.com> schrieb im Newsbeitrag
news:c12upf$p0h$1@is.intellij.net...

This was a bug in build 64 that caused some internal events to be viewed

as

public by ReSharper (no other consequences on ReSharper from this
exceptions). The bug was fixed in build 65.

>

--
Andrey Simanovsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>
>

<T-Online@T-Online.de> wrote in message

news:c12tc3$eg3$1@is.intellij.net...

The Add-In ist installed and worked so far (with some issues, already
discussed on other threads in this newsgroup)

>

I get this output in the debugger-console, when VS is opening a solution

(on

stratup or
by using the "open" command):

>

------
System.ApplicationException: Event without adder/remover/raiser :

ClearCache

in
type GC

>

System.ApplicationException: Event without adder/remover/raiser :
RowHeaderClick
in type DataGrid

>

System.ApplicationException: Event without adder/remover/raiser :

NodeClick

in t
ype DataGrid

>

System.ApplicationException: Event without adder/remover/raiser :
ValidationEven
tHandler in type XmlTextReader

>

System.ApplicationException: Event without adder/remover/raiser :
InternalValida
tionEventHandler in type XmlValidatingReader

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataColumn

>

System.ApplicationException: Event without adder/remover/raiser :
CollectionChan
ging in type DataColumnCollection

>

System.ApplicationException: Event without adder/remover/raiser :
ColumnProperty
Changed in type DataColumnCollection

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataRelation

>

System.ApplicationException: Event without adder/remover/raiser :
CollectionChan
ging in type DataRelationCollection

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataSet

>

System.ApplicationException: Event without adder/remover/raiser :
DataRowCreated
in type DataSet

>

System.ApplicationException: Event without adder/remover/raiser :
ClearFunctionC
alled in type DataSet

>

System.ApplicationException: Event without adder/remover/raiser :
PropertyChangi
ng in type DataTable

>

System.ApplicationException: Event without adder/remover/raiser :
DefaultAuthent
ication in type HttpApplication

>

System.ApplicationException: Event without adder/remover/raiser :
BeforeDoneWith
Session in type HttpContext

>
>

"Dmitry Shaporenkov(JetBrains)" <dsha@jetbrains.com> schrieb im

Newsbeitrag

news:c12nln$37g$1@is.intellij.net...

SThorin,

>

do you see any exceptions during VS.NET / ReSharper startup?
Please also make sure that the ReSharper is loaded (Tools|Add-in

manager)

when you are looking for ReSharper commands.

>

Thanks for your information, we'll try ReSharper on german editions of
VS.NET.

>

>
>
>

>
>


0

Please sign in to leave a comment.