Build 78: installer still broken

Installer still broken in 78 when installing over a previous version. The .Interop assemblies are not found but yet the installaction succeeds (that, I feel, is a big problem). A "repair" action seems to fix things.

-Michael

4 comments
Comment actions Permalink

Michael,

surely, as you have noticed, installer is a big pain for us. We're still
looking for better tools
than MSI, but without success so far. Unfortunately, current installer is
unreliable with regard to both
installation and uninstallation, and the only consolation is that the
problems it creates have normally very
easy workarounds.

Thanks for your patience.

"Michael Teper" <michael.dot.teper@convade.dot.com> wrote in message
news:c668mg$s4l$1@is.intellij.net...

Installer still broken in 78 when installing over a previous version. The

.Interop assemblies are not found but yet the installaction succeeds (that,
I feel, is a big problem). A "repair" action seems to fix things.
>

-Michael




0
Comment actions Permalink

I get a regasm error and a repair fixes nothng.

"Michael Teper" <michael.dot.teper@convade.dot.com> wrote in message
news:c668mg$s4l$1@is.intellij.net...

Installer still broken in 78 when installing over a previous version. The
.Interop assemblies are not found but yet the installaction succeeds
(that, I feel, is a big problem). A "repair" action seems to fix things.

>

-Michael



0
Comment actions Permalink

Derek,

the problem is most likely connected with 'Extensibility.dll' that should be
installed in GAC. You'll need to install it there manually by running

gacutil /i Extensibility.dll


Please also refer to the post you've requested in another thread.

"Derek" <derek@btacinc.com> wrote in message
news:c66bnk$fnc$1@is.intellij.net...

I get a regasm error and a repair fixes nothng.

>

"Michael Teper" <michael.dot.teper@convade.dot.com> wrote in message
news:c668mg$s4l$1@is.intellij.net...

Installer still broken in 78 when installing over a previous version.

The

.Interop assemblies are not found but yet the installaction succeeds
(that, I feel, is a big problem). A "repair" action seems to fix things.

>

-Michael

>
>


0
Comment actions Permalink

Could you please create a binary distribution package? That is, simply binaries in zip file and plain text file with required actions to install things manually? That way you could gather information from people about what are the problems during installation. Probably different machine and VS configuraitons is something to do with expected installation sequence...

0

Please sign in to leave a comment.