Build 79 - Code Analysis

Hi

I've just installed #79. As I'm working VS takes to processor to 100% for 10-15 seconds, preventing me working. Very soon after it completes this, it starts all over again (less than 30 seconds). I have been working for about three hours without this problem.

There is a vertical bar at the right of the text editor that says 'analysis complete' in a tooltip and has a few red lines on it to indicate the places where the code does not currently compile.

Is it Resharper analysing my code as I go to produce the bar on the right? Can I turn it off if so?

Thanks again

Sean

6 comments
Comment actions Permalink

I've just uninstalled Resharper and the problem has gone away. I now feel lost and lonely without Resharper ;( Help!!!!

0
Comment actions Permalink

Sean,

The vertical bar on the right is shown by ReSharper. It goes as a part of
error highlighting. It is shown always (the bar itself it does not require
significant resources). The contents of the bar is dependent on the
highlighting. The highlighting is performed in the background as you type.

What is the size of the file you are editing? And what does the managed
memory usage indicator in the status bar tell? You can turn off highlighting
to try to avoid CPU spikes.

--
Andrey Simanovsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



"sean kearon" <no_mail@jetbrains.com> wrote in message
news:31874858.1083934601650.JavaMail.itn@is.intellij.net...

Hi

>

I've just installed #79. As I'm working VS takes to processor to 100% for

10-15 seconds, preventing me working. Very soon after it completes this,
it starts all over again (less than 30 seconds). I have been working for
about three hours without this problem.
>

There is a vertical bar at the right of the text editor that says

'analysis complete' in a tooltip and has a few red lines on it to indicate
the places where the code does not currently compile.
>

Is it Resharper analysing my code as I go to produce the bar on the right?

Can I turn it off if so?
>

Thanks again

>

Sean



0
Comment actions Permalink

Turn off syntax highlighting in the Resharper options. This will make
a huge difference, but you lose the bells and whistles. They know about
the performance issues and are working on it.


0
Comment actions Permalink

Small additional note:
to enable / disable background highlighting, use Toos -> Options ->
ReSharper -> General -> Code Insight

"Andrey Simanovsky (JetBrains)" <ands@jetbrains.com> wrote in message
news:c7g2p0$buo$1@is.intellij.net...

Sean,

>

The vertical bar on the right is shown by ReSharper. It goes as a part of
error highlighting. It is shown always (the bar itself it does not require
significant resources). The contents of the bar is dependent on the
highlighting. The highlighting is performed in the background as you type.

>

What is the size of the file you are editing? And what does the managed
memory usage indicator in the status bar tell? You can turn off

highlighting

to try to avoid CPU spikes.

>

--
Andrey Simanovsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>
>

"sean kearon" <no_mail@jetbrains.com> wrote in message
news:31874858.1083934601650.JavaMail.itn@is.intellij.net...

Hi

>

I've just installed #79. As I'm working VS takes to processor to 100%

for

10-15 seconds, preventing me working. Very soon after it completes this,
it starts all over again (less than 30 seconds). I have been working for
about three hours without this problem.
>

There is a vertical bar at the right of the text editor that says

'analysis complete' in a tooltip and has a few red lines on it to indicate
the places where the code does not currently compile.
>

Is it Resharper analysing my code as I go to produce the bar on the

right?

Can I turn it off if so?
>

Thanks again

>

Sean

>
>


0
Comment actions Permalink

Thanks, I will reinstall and try turning off the highlighting. The file has 21 classes over 4000 lines of non-blank code at about 40% comments. The project has about 100 classes over 13000 non-blank lines of code at about 30% comments.

Thanks

Sean

0
Comment actions Permalink

Thanks all, that has worked!

0

Please sign in to leave a comment.