.NET Core Class libraries with framework set to netstandard1.5 not recognised in referencing projects

Answered

Even though Visual Studio performs the build without errors I'm getting red text (symbol not found) for symbols in .NET Core class libraries where the framework is "netstandard1.5".

I've tried clearing the cache and suspending Resharper to no avail. What eventually did work was changing the class library's framework to "netcoreapp1.0" and adding the "Microsoft.NETCore.App" dependency. Any idea what's going on?

4 comments
Comment actions Permalink
Official comment

ReSharper has not supported .NET Core RC2 Preview yet - feel free to follow https://youtrack.jetbrains.com/issue/RSRP-458817

Thanks! 

Comment actions Permalink

The migration guide states that libraries should use netstandard1.5 as framework in project.json. Applications netcoreapp1.0.

When I reference a netstandard1.5 library within a netstandard1.5 library Resharper recognizes the classes in the included library. But if I include a netstandard1.5 library in a netcore1.0 application (console or web) the classes of the libraries are not recognized in the netcore1.0 application.

I had to disable Resharper.

 

2
Comment actions Permalink

I'm having the same problem, accessing a .NETStandard class library (netstandard1.6) from a .NETCoreApp.

I'm working in Visual Studio 2015 Update 3 and .NET Core 1.0. I have a Web API project which is of type .NETCoreApp v1.0. When I add a .NET Core class library, it is of type .NETStandard v1.6. I can add this library to the Web API project as a reference, but it is not recognised when I try to add using statements or reference objects in the class library.

Both the .NETCoreApp and the .NETStandard class library compile and the app runs and calls into the library.

0
Comment actions Permalink

@Peter Wood, please try installing R# 2016.2 EAP https://confluence.jetbrains.com/display/ReSharper/ReSharper+2016.2+EAP, since R# 2016.1.2 does not support.NET Core 1.0.

Thanks! 

0

Please sign in to leave a comment.