Problem with build 89

I just downloaded and installed build 89 and there was a big suprise: All solutions-properties are set to "". So I can not build any solution. So i put all properties back saved the project. After reopen the VS all solution-properties are set to "" again.
I uninstalled build 89 and .. nothing changed. after reinstalling build 88 VS works correctly.

Has anybody a idea whats happening to my VS ?

Thanx

Felix Weyde

PS: please excuse my bad english :)

7 comments
Comment actions Permalink

I had the same problem here!
All my configurations lost :(
After installing Build 89. I did NOT have this problem on my laptop though (and I had Build86 removed before).
Major difference is the os, Windows 2000 and WindowsXP on the laptop. The strange thing is that the project files are perfectly in order, just the property dialog doesnt show them anymore and also they are not used for the build.
( Another note: on W2k Reshaper has no own icon in the Add/Remove Components dialog )
Deinstall didnt help
Reinstalling Build86 did, but I cant used it anymore, since its license expired :(
Have a nice day,
Guido Stinnez

0
Comment actions Permalink

Guido, please follow the instructions at the end of the page
http://www.jetbrains.net/confluence/display/ReSharper/InstallationProblemsWorkaround.
You'll need
to register csproj.dll to restore your properties.

"Guido Stinnez" <no_mail@jetbrains.com> wrote in message
news:7217886.1088418914132.JavaMail.itn@is.intellij.net...

I had the same problem here!
All my configurations lost :(
After installing Build 89. I did NOT have this problem on my laptop though

(and I had Build86 removed before).

Major difference is the os, Windows 2000 and WindowsXP on the laptop. The

strange thing is that the project files are perfectly in order, just the
property dialog doesnt show them anymore and also they are not used for the
build.

( Another note: on W2k Reshaper has no own icon in the Add/Remove

Components dialog )

Deinstall didnt help
Reinstalling Build86 did, but I cant used it anymore, since its license

expired :(

Have a nice day,
Guido Stinnez



0
Comment actions Permalink

Felix Weyde wrote:

I just downloaded and installed build 89 and there was a big suprise: All solutions-properties are set to "". So I can not build any solution. So i put all properties back saved the project. After reopen the VS all solution-properties are set to "" again.
I uninstalled build 89 and .. nothing changed. after reinstalling build 88 VS works correctly.

Has anybody a idea whats happening to my VS ?

Thanx

Felix Weyde

PS: please excuse my bad english :)


I had exactly the same problem, so I hope someone will address it soon.
Fortunately the same workaroud (reinstallation of build 88) did the job
for me too.

BR,

Hristo Doynov

0
Comment actions Permalink

Hristo,

you can also try to follow the instructions at
http://www.jetbrains.net/confluence/display/ReSharper/InstallationProblemsWorkaround
instead of reinstalling 89. Since build 90 we use a new installer which will
hopefully be free of this and other related problems.

"Hristo Doynov" <hdoinov@yahoo.com> wrote in message
news:cbpehv$71p$1@is.intellij.net...

Felix Weyde wrote:

I just downloaded and installed build 89 and there was a big suprise:

All solutions-properties are set to "". So I can not build any solution. So
i put all properties back saved the project. After reopen the VS all
solution-properties are set to "" again.

I uninstalled build 89 and .. nothing changed. after reinstalling build

88 VS works correctly.

>

Has anybody a idea whats happening to my VS ?

>

Thanx

>

Felix Weyde

>

PS: please excuse my bad english :)

>

I had exactly the same problem, so I hope someone will address it soon.
Fortunately the same workaroud (reinstallation of build 88) did the job
for me too.

>

BR,

>

Hristo Doynov



0
Comment actions Permalink

Dmitry Shaporenkov (JetBrains) wrote:

Hristo,

you can also try to follow the instructions at
http://www.jetbrains.net/confluence/display/ReSharper/InstallationProblemsWorkaround
instead of reinstalling 89. Since build 90 we use a new installer which will
hopefully be free of this and other related problems.


Sad to say it, but actualy installing build 90 didn't remedy the problem
at all. I apologize for being stupid enough not to take a peek in the
Installation Problems Workarounds, it was indeed the deregistration of
the csproj.dll that caused all the trouble. My point is that even with
build 90 and its new installer, I still hat to resort to re-registering
the csproj.dll.


"Hristo Doynov" <hdoinov@yahoo.com> wrote in message
news:cbpehv$71p$1@is.intellij.net...

>>Felix Weyde wrote:
>>
>>>I just downloaded and installed build 89 and there was a big suprise:


All solutions-properties are set to "". So I can not build any solution. So
i put all properties back saved the project. After reopen the VS all
solution-properties are set to "" again.

>>>I uninstalled build 89 and .. nothing changed. after reinstalling build


88 VS works correctly.

>>>Has anybody a idea whats happening to my VS ?
>>>
>>>Thanx
>>>
>>>Felix Weyde
>>>
>>>PS: please excuse my bad english :)
>>
>>I had exactly the same problem, so I hope someone will address it soon.
>>Fortunately the same workaroud (reinstallation of build 88) did the job
>>for me too.
>>
>>BR,
>>
>>Hristo Doynov



BR, Hristo Doynov

0
Comment actions Permalink

Hristo,

actually, installing build 90 could not remedy this problem because since
build 90 installer does not know anything about
csproj.dll (and hence it cannot register it). What I meant was that
uninstalling of build 90 should not break VS.NET by unregistering this
dll.
So, if you register csproj.dll, install build 90, then uninstall 90,
csproj.dll should not get unregistered. Is this false in your
case?

"Hristo Doynov" <hdoinov@yahoo.com> wrote in message
news:cc0j69$6j6$1@is.intellij.net...

Dmitry Shaporenkov (JetBrains) wrote:

Hristo,

>

you can also try to follow the instructions at

>

http://www.jetbrains.net/confluence/display/ReSharper/InstallationProblemsWorkaround

instead of reinstalling 89. Since build 90 we use a new installer which

will

hopefully be free of this and other related problems.

>

Sad to say it, but actualy installing build 90 didn't remedy the problem
at all. I apologize for being stupid enough not to take a peek in the
Installation Problems Workarounds, it was indeed the deregistration of
the csproj.dll that caused all the trouble. My point is that even with
build 90 and its new installer, I still hat to resort to re-registering
the csproj.dll.

>

>

"Hristo Doynov" <hdoinov@yahoo.com> wrote in message
news:cbpehv$71p$1@is.intellij.net...

>
>>Felix Weyde wrote:
>>
>>>I just downloaded and installed build 89 and there was a big suprise:
>

All solutions-properties are set to "". So I can not build any solution.

So

i put all properties back saved the project. After reopen the VS all
solution-properties are set to "" again.

>
>>>I uninstalled build 89 and .. nothing changed. after reinstalling build
>

88 VS works correctly.

>
>>>Has anybody a idea whats happening to my VS ?
>>>
>>>Thanx
>>>
>>>Felix Weyde
>>>
>>>PS: please excuse my bad english :)
>>
>>I had exactly the same problem, so I hope someone will address it soon.
>>Fortunately the same workaroud (reinstallation of build 88) did the job
>>for me too.
>>
>>BR,
>>
>>Hristo Doynov
>
>
>

>

BR, Hristo Doynov



0
Comment actions Permalink

Dmitry Shaporenkov (JetBrains) wrote:

Hristo,

actually, installing build 90 could not remedy this problem because since
build 90 installer does not know anything about
csproj.dll (and hence it cannot register it). What I meant was that
uninstalling of build 90 should not break VS.NET by unregistering this
dll.
So, if you register csproj.dll, install build 90, then uninstall 90,
csproj.dll should not get unregistered. Is this false in your
case?


Nope, after re-registering the csproj.dll and uninstalling build 90,
there was no problem at all. Sorry for the missunderstanding :)

"Hristo Doynov" <hdoinov@yahoo.com> wrote in message
news:cc0j69$6j6$1@is.intellij.net...

>>Dmitry Shaporenkov (JetBrains) wrote:
>>
>>>Hristo,
>>>
>>>you can also try to follow the instructions at
>>>


http://www.jetbrains.net/confluence/display/ReSharper/InstallationProblemsWorkaround

>>>instead of reinstalling 89. Since build 90 we use a new installer which


will

>>>hopefully be free of this and other related problems.
>>
>>Sad to say it, but actualy installing build 90 didn't remedy the problem
>> at all. I apologize for being stupid enough not to take a peek in the
>>Installation Problems Workarounds, it was indeed the deregistration of
>>the csproj.dll that caused all the trouble. My point is that even with
>>build 90 and its new installer, I still hat to resort to re-registering
>>the csproj.dll.
>>
>>
>>>"Hristo Doynov" <hdoinov@yahoo.com> wrote in message
>>>news:cbpehv$71p$1@is.intellij.net...
>>>
>>>
>>>>Felix Weyde wrote:
>>>>
>>>>
>>>>>I just downloaded and installed build 89 and there was a big suprise:
>>>
>>>All solutions-properties are set to "". So I can not build any solution.


So

>>>i put all properties back saved the project. After reopen the VS all
>>>solution-properties are set to "" again.
>>>
>>>
>>>>>I uninstalled build 89 and .. nothing changed. after reinstalling build
>>>
>>>88 VS works correctly.
>>>
>>>
>>>>>Has anybody a idea whats happening to my VS ?
>>>>>
>>>>>Thanx
>>>>>
>>>>>Felix Weyde
>>>>>
>>>>>PS: please excuse my bad english :)
>>>>
>>>>I had exactly the same problem, so I hope someone will address it soon.
>>>>Fortunately the same workaroud (reinstallation of build 88) did the job
>>>>for me too.
>>>>
>>>>BR,
>>>>
>>>>Hristo Doynov
>>>
>>>
>>>
BR, Hristo Doynov

0

Please sign in to leave a comment.